Emails using SMTP not working in a new installation-CentOS 7 -version 3.9 [incorrect user in cron]

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

-The problem is that invitations are not sent.

-The mail test both from the web and as the command is sent correctly.

/usr/share/php/passbolt/bin/cake passbolt send_test_email –"

-The status of crond.service is running

-I have also checked health:
su - nginx -s /bin/bash -c “/usr/share/php/passbolt/bin/cake passbolt healthcheck”

-If I run:
/usr/share/php/passbolt/bin/cake EmailQueue.sender

The emails are sent.

Hi @aintziralc You checked the box saying you provided your healthcheck but it’s not included.

Let’s confirm the emails are not being sent, or get some more details about them.

What are the database results of:
select sent,locked,send_tries,created,send_at,error from email_queue where template='AN/user_register_admin';

I have executed the query and the result is the following

and de healthcheck

@aintziralc Thanks for the additional info that is helpful. It appears they are all sent fine.

Regarding the invitations that aren’t being sent, can you provide more details?

Who (kind of user) is doing what (which page, which button, which activity, etc) in the app that creates these invitations?

I should add that if you can create the scenario where one has not been delivered, and then confirm with the db command above that is better. Meaning, don’t manually run the sender and then run the db command. Also, I’ve assumed a particular template but maybe you are referring to something else.

The problem is when creating a user the invitation that is sent to him and when sharing passwords.

I just made two shipments and executing the query this appears

  • Later I run
    /usr/share/php/passbolt/bin/cake EmailQueue.sender

and the two emails have been sent

I run the query again

@aintziralc Ok great info. This makes me think CRON is not working properly.

We need to verify the contents of the passbolt cron file found in /etc/cron.d and also look for system messages that may indicate cron failure.

This is the content of crond.d

hey @aintziralc the issue here is that the www-data user doesn’t exist on CentOS, you’ll need to change that to the nginx user. This was an issue we recently discovered on the RPM based distros.

I changed it and it works now. Thanks!!

1 Like

Sorry for that it will be changed in the up coming release