Error Durning Install on Debian

[X ] I have read intro post: About the Installation Issues category
[ X] I have read the tutorials, help and searched for similar issues
[ X] I provide relevant information about my server (component names and versions, etc.)
[ X] I provide a copy of my logs and healthcheck
[ x] I describe the steps I have taken to trouble shoot the problem
[ X] I describe the steps on how to reproduce the issue

I am trying to install passbolt on a VM. I have tried Ubuntu, and Debian. They are fresh installs of the latest versions. I keep getting this message:
Triggering nginx reload …
Processing triggers for libc-bin (2.36-9+deb12u4) …
Processing triggers for man-db (2.11.2-2) …
Processing triggers for php8.2-cli (8.2.7-1~deb12u1) …
Processing triggers for php8.2-fpm (8.2.7-1~deb12u1) …
Processing triggers for mariadb-server (1:10.11.6-0+deb12u1) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

and the install stops. I try to run the install command again and it will finish but doesn’t load the passbolt website just the nginx pages that tells me that it worked but there is more config to be done.

hey @Dahoward welcome to the forum!

This looks like the output for after you finished configuring on the command line, is that correct?

If so what configuration options did you choose there?

I created a DB and choose none for the Cert., I specified an IP address for the website.

What do you have in /var/log/dpkg.log regarding this?

Just to be clear the VMs you are installing on are completely vanilla, right?

Yes, completely vanilla VM, I have no data in dpkg.log but I do have install data in dpkg.log.1.

I have ran into too many issues with trying to install Passbolt on Debian/Ubuntu/AlmaLinux/RockyLink and I’ve given up! The installation script just does not work! I have receive different errors in the logs from database errors to admin user permission errors.

It’s a shame really I was going to implement the enterprise versions Passbolt to the many companies that I support, but alas, it just wasn’t mean to be. With having so many issues with just trying to get the app installed, I’m afraid of what issues that come up during production.

I will revisit Passbolt after some time passes and the app has some more development time to mature and get the installation script working correctly. I’m still rooting for Passbolt to be successful. I hope to be back sometime in the future!

I’m a bit surprised that you didn’t manage to install passbolt at all. We’ll be happy to help if you could share information about the errors in another thread.

Beware that FUD is against our code of conduct. Just a heads up, considering it’s your first post, you might not know that.

As am I… Maybe I will take you up on your offer next week, when I have time I will respond to offer and thank you! I did spend upwards of 8 hours searching & researching the help forums and tried all the solutions that were posted (with the exception of the one where the user had to install a vm on a laptop and then transfer it over to the Hyper-V server). My clients don’t use Hyper-V (they have paid subs of Proxmox).

My apologies, if I’ve offended anyone, I know people do work hard to make the best software they can. Like I mentioned in my post, I’m still a fan and love the concept of Passbolt! To clearify, I did manage every time to install Passbolt up to the last step of actually adding the admin user. Site came up asking for an email verification got stuck there.

I realise that I was testing the community edition, but I like put software through some basic testing before showing clients, and the CD edition is usually the best way start the pitch on the benefit of the app.

Again sorry if I mentioned something that I shouldn’t have, I will circle around some time in the future and take another stab at it. Thank you for your reply!


Heads up! I took another stab at it this weekend and I found the solution that actually worked, to finally complete the install. As I already had a Debian 12 vm configured, I performed a sudo dpkg-reconfigure passbolt-ce-server
which I derived from this post (Connection refused when doing initial web-based setup after install - #7 by Decoy256 - Look at garret’s post 7). That did the trick!

I’m going to be thoroughly testing Passbolt over the next month to see if it’s a solution that would benefit my enterprise customers!

Cheers all!