Error: The sender name should not be empty - when accessing email server settings

[x ] I have read intro post: About the Installation Issues category
[ x] I have read the tutorials, help and searched for similar issues
[ x] I provide relevant information about my server (component names and versions, etc.)
[ x] I provide a copy of my logs and healthcheck
[ x] I describe the steps I have taken to trouble shoot the problem
[ x] I describe the steps on how to reproduce the issue

I installed passbolt 3.9.0-2-ce on Azure Kubernetes Cluster using helm chart GitHub - mmz-srf/passbolt-helm: Passbolt Kubernetes Helm Charts

inside values.yaml I provided email server configuration

  enabled: true
  from: ...
  port: 587
  tls: true
  timeout: 30
  username: ...
  password: ...

and it works fine I get emails… however when I try to go in UI to administration → Email Server I get this error:

“code”: 400,
“body”: {
“sender_name”: {
“_empty”: “The sender name should not be empty.”

passboltApiFetchError: Could not validate the smtp settings.
at xe.fetchAndHandleResponse (api-app.js?v=3.9.0:2:168086)
at async xe.findAll (api-app.js?v=3.9.0:2:166031)
at async Object.find (api-app.js?v=3.9.0:2:448902)
at async xn.findSmtpSettings (api-app.js?v=3.9.0:2:450686)
at async Mn.componentDidMount (api-app.js?v=3.9.0:2:464104)
handleError @ api-app.js?v=3.9.0:2

once I click though error and I go to email server setting “Other” the form is empty and I get warning:

Warning: These are the settings provided by a configuration file. If you save it, will ignore the settings on file and use the ones from the database.

I think the biggest problem is pop up error with 400 status as it seems that something is wrong… also there is nothing in the passbolt output log

Hi @rafhuser ,

thanks for reporting your issue. Indeed the 400 is a bit confusing for the user.

Still I do not see how this error showed up since the sender name has a default value defined in the config/app.php file.

Did you modify the config/app.php file, in particular the Email.default.transport configuration?

What was the output of the healthcheck
bin/cake passbolt healthcheck --smtpSettings

Thank you it works now, health check showed the problem.

it was missing EMAIL_DEFAULT_FROM_NAME env variable value which I provide as helm value that wasn’t documented in helm repo

Thanks for the feedback @rafhuser . I have created an issue on the repo to update the docs.

Thank you, i have implemented a fix in the docs of the helm charts and in the default values file as well.

Best regards

1 Like