First mail configuration

Checklist
I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

Hello,

I think this problem is recurrent but I did not find a solution to my problem on the forum and google.

When I first set up the mail account on the exchange server, I want to configure it, but it returns that the credentials are not good.

I am annoyed because as this is blocked I can not access the administration interface.

If someone could help me it would be very nice because I spent a lot of time on this installation (I met a lot of problems) and now I’m almost at the end but I’m blocked and have no idea…

For information I run Debian 11.

Thanks a lot !

Good evening / day to you

Hello @floMAC78 Welcome to the forum!

You will need to provide more details like:

  • who is your mail provider?
  • show mail configuration settings in passbolt, or explain steps you took (remove sensitive info first)
  • what action were you taking before you got a message that credentials were bad?
  • what was the actual message?

And also make sure to review Passbolt Help | Why are my emails not being sent?

Hello, first of all thank you for your answer.

  • who is your mail provider?
    EXCHANGE SERVER hosted internally

  • show mail configuration settings in passbolt, or explain steps you took (remove sensitive info first)

  • what action were you taking before you got a message that credentials were bad?
    I have done the configuration steps, but I did not succeed in the email step.

  • what was the actual message?
    on the picture above

Also until then you can still connect to your server to generate a link for a new admin.

sudo su -s /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt register_user -u email@domain.com -f FirstName -l LastName -r admin" www-data

I do not have a local exchange to test but could it be that you have to whitelist your server IP in order that it is accepted by MS exchange?

1 Like

Thank you very much, indeed I have access to the interface now. I will be able to communicate you my mail settings !

Capture d’écran 2022-10-14 à 12.07.55

Voila :grinning:

Can you try with an IP for the host?

Can you share as well the result of the command:

sudo -H -u www-data bash -c "/usr/share/php/passbolt/bin/cake passbolt send_test_email --recipient=youremail@domain.com"

Merci :slight_smile:

@floMAC78 Thanks for the additional info!

Have you had a chance to review this? Office365 SMTP: upcoming basic auth changes not affecting SMTP (though MFA + app passwords recommended)

It has a couple links to other threads with the same issue.

In the screenshot you don’t show the results after the AUTH LOGIN. Your server doesn’t permit PLAIN so it’s OK to ignore the first error, that’s normal.

What is the error after AUTH LOGIN?

Hello, sorry for the time of answer… Here is the result:

Open source password manager for teams

Debug email shell

Email configuration

Host: xxxxxxxxx.xxxx
Port: 587
Username: xxxxxxxxxxx
Password: *********
TLS: true
Sending email from: xxxxxx srv xxxxxxxxx@xxxx
Sending email to: xxxxxxxxxx@xxxx

Trace
[220] exchange.xxxxxx Microsoft ESMTP MAIL Service ready at Mon, 17 Oct 2022 17:08:29 +0200

EHLO localhost
[250] exchange.xxxx Hello [xxx.xxx.xxx.xxx]
[250] SIZE 36700160
[250] PIPELINING
[250] DSN
[250] ENHANCEDSTATUSCODES
[250] STARTTLS
[250] AUTH GSSAPI NTLM
[250] 8BITMIME
[250] BINARYMIME
[250] CHUNKING
STARTTLS
[220] 2.0.0 SMTP server ready
EHLO localhost
[250] exchange.xxxx Hello [xxx.xxx.xxx.xxx]
[250] SIZE 36700160
[250] PIPELINING
[250] DSN
[250] ENHANCEDSTATUSCODES
[250] AUTH GSSAPI NTLM LOGIN
[250] 8BITMIME
[250] BINARYMIME
[250] CHUNKING
AUTH PLAIN AHBhc3N3b3JkAFBuamhJdFBNR3NvdVRvMGpaNEZYdGhBag==
[504] 5.7.4 Unrecognized authentication type
AUTH LOGIN
[334] VXNlcm5hbWU6


[334] UGFzc3dvcmQ6
Could not send the test email.
Error: SMTP server did not accept the password.

Thank you for your help !

Merci pour votre aide :grinning:

Normally no problem on this side because I have GLPI and the scanner that communicates by mail.

@floMAC78 Is the recipient of the passbolt email internal or external to your organization?

In the above configuration internal, but I tried external too…

Hi @floMAC78
I’m not sure if this might be a solution but you can try double checking your Microsoft admin account.

Make sure 2FA is enabled.
Generate an APP Password for the email that you are using for SMTP.

Then try the process again. I had a client with a similar error; although it was not related to passbolt.

The client had created an APP password for the wrong email. This could also be an issue.

Regards
Bond

@floMAC78 It’s a bit hard to verify your config because it’s completely obscured. Would you mind replacing xxs with things like “remote.domain”, “remoteip” so it’s descriptive? That will help thanks.

1 Like