I can not login

[X] I have read intro post: About the Installation Issues category
[X] I have read the tutorials, help and searched for similar issues
[X] I provide relevant information about my server (component names and versions, etc.)
[X] I provide a copy of my logs and healthcheck
[ ] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Information about my server on VM
|Distributor ID:|Ubuntu|
|Description:|Ubuntu 18.04.2 LTS|
nginx version: nginx/1.14.0
Server: MariaDB
Server version: 10.1.38-MariaDB-0ubuntu0.18.04.2 Ubuntu 18.04
Protocol version: 10
PHP 7.2.17
Passbolt version 2.10.0

____ __ ____
/ __ ____ _____ / / ____ / / /
/ /
/ / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Healthcheck shell


[PASS] PHP version 7.2.17-0ubuntu0.18.04.1.
[PASS] PCRE compiled with unicode support.
[PASS] The temporary directory and its content are writable.
[PASS] The public image directory and its content are writable.
[PASS] The logs directory and its content are writable.
[PASS] GD or Imagick extension is installed.
[PASS] Intl extension is installed.
[PASS] Mbstring extension is installed.

Config files

[PASS] The application config file is present
[PASS] The passbolt config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Full base url is set to https://passbolt.local
[PASS] App.fullBaseUrl validation OK.
[PASS] /healthcheck/status is reachable.

SSL Certificate

[PASS] SSL peer certificate validates
[PASS] Hostname is matching in SSL certificate.
[WARN] Using a self-signed certificate


[PASS] The application is able to connect to the database
[PASS] 26 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded.
[PASS] The environment variable GNUPGHOME is set to /home/www-data/.gnupg.
[PASS] The directory /home/www-data/.gnupg containing the keyring is writable by the webserver user.
[PASS] The server gpg key is not the default one
[PASS] The public key file is defined in config/passbolt.php and readable.
[PASS] The private key file is defined in config/passbolt.php and readable.
[PASS] The server key fingerprint matches the one defined in config/passbolt.php.
[PASS] The server public key defined in the config/passbolt.php (or environment variables) is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt a message.
[PASS] The private key can be used to sign a message.
[PASS] The public and private keys can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.
[PASS] The private key can be used to decrypt and verify a message.
[PASS] The public key can be used to verify a signature.

Application configuration

[PASS] Using latest passbolt version (2.10.0).
[PASS] Passbolt is configured to force SSL use.
[PASS] App.fullBaseUrl is set to HTTPS.
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[WARN] Registration is open to everyone.
[HELP] Make sure this instance is not publicly available on the internet.
[HELP] Or set passbolt.registration.public to false in config/passbolt.php.
[PASS] Serving the compiled version of the javascript app
[PASS] All email notifications will be sent.

No error found. Nice one sparky!

Previously when entering the web address I missed a GPG warning, but in the healcheck everything was correct, I read an article and reinstalled the web browser extension. Then it does not come back out, but I try to register a new account or recover the previously created administrator account and nothing. It does not send any mail, and that already I made a test mail and sends it to me correctly
If you receive this email, it means that your passbolt smtp configuration is working fine.).
I’m sorry, I do not speak English very well and I use the translator.

no help?
Thanks to everyone.

Did you check your spam ?

How did you install passbolt ? Did you use the official install script or you installed passbolt from scratch ? It looks like cron is not configured.

I installed passbolt on my private server from scratch and have always checked the spam tray

In the section 9. of the passbolt from source documentation, there is a mention to the cron configuration. You might have missed this part.

You can add a cron call to the script so the emails will be sent every minute. Add the following line to you crontab:

 * * * * * /var/www/passbolt/bin/cake EmailQueue.sender >> /var/log/passbolt.log

Sure, I skipped that step because I used the Ubuntu 18 guide and that step does not appear. I have configured the contrab but I still do not receive recovery or registration emails.

@antonio Did you try to execute manually the command
/var/www/passbolt/bin/cake EmailQueue.sender ? What is the output ?

Exception: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘EmailQueue.to’ in ‘field list’ in [/var/www/passbolt/vendor/cakephp/cakephp/src/Database/Statement/MysqlStatement.php, line 39]

It looks like your dependencies are not up to date.
composer install --no-dev (from inside your passbolt directory, as your webserver user).

Ups, thanks but…
Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating autoload files

thadafinser/package-info: Generating class…
thadafinser/package-info: …generating class
Set Folder Permissions ? (Default to Y) [Y,n]? y
No Security.salt placeholder to replace.

It looks like all the migration scripts have not all been executed.
You should be able to install the missing tables by running the following command su -s /bin/bash -c "./bin/cake passbolt migrate" www-data.

Can you please point us the doc you used to install passbolt ?

www-data@passbolt:~$ /var/www/passbolt/bin/cake passbolt migrate

 ____                  __          ____  
/ __ \____  _____ ____/ /_  ____  / / /_ 

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Running migration scripts.

using migration paths

  • /var/www/passbolt/config/Migrations
    using seed paths
  • /var/www/passbolt/config/Seeds
    using environment default
    using adapter mysql
    using database passbolt

All Done. Took 0.8487s
Cleared default cache
Cleared cake_core cache
Cleared cake_model cache

This doc:

Hello @antonio,

Another user is experiencing the same issue as you, and he found a way to make it works by cleaning the composer cache.

Take a look to this comment: Mail issue with users I added

We will investigate this issue on our side.


Just after entering the previous command(/var/www/passbolt/bin/cake passbolt migrate), I tried again and it worked. I already received the verification email and it was all right.
Still, do you advise me to clean the cache?
I would also like to know what is the final document to make a clean and correct installation, I suppose it is to combine the documents of “ubuntu” and “fromsource code”, no??

1 Like

Thank you for the follow up.

The documentation you used is the good one, we’ll investigate the issue that happened to you and correct it if required.

You don’t need to flush the cache if it’s working for you now.