Import bug with tags


#1

We successfully can import records into passbolt. The format is like this:

Title,Username,URL,Password,Notes,Type

In field “Type” we have tags in the format #tag

The bug is that at the end all imported records have the tag from the last record. All records get the same tag.

Strange that no one else experienced this. Or even more realistic - what is our mistake? :slight_smile:


#2

:slight_smile: Someone any idea?


#3

Hi @kingfisher,

Thanks for the report. This bug has actually been fixed yesterday with the new release of the extension 2.1.0. Can you try again (make sure your extension is updated to 2.1.0 before) and let me know if it works fine for you?

Thanks.


#4

Thank you! We updated our installation:

git pull origin master
composer install
./bin/cake passbolt migrate --backup

No difference after importing the passwords.

/healtcheck shows one error:

The database schema is not up to date.

./bin/cake passbolt migrate did not throw an error.

Any idea?

bash-4.2$ cat config/version.php
<?php
return [
    'passbolt' => [
        'version' => '2.1.1',
        'name' => 'Loungin'
    ]
];

#5

Alright. Do not pay attention to the message The database schema is not up to date. . We have also noticed this issue. The migration is executed correctly but for some reason is not tracked in the database. We’ll patch it in the next release, but there is nothing to worry about for now as it will not impact the functioning of passbolt.

Could you tell me what is the version of your passbolt browser add-on? It should be v2.1.0


#6

Browser add on has Version 2.0.10


#7

Alright. My bad, the 2.1.0 was not live yet in the chrome webstore. It is now and your add-on should update automatically shortly.
Once it is done, please try to import again, and let me know if it’s fixed.
Thanks!!


#8

Okay :slight_smile:
Could you give me a hint how to reinitiate the Migration so that the table account_settings will be created. We tried around by restoring the latest db backup :confused: and now the table is missing.


#9

Running the migration script again should do the trick: ./bin/cake passbolt migrate --backup. Unless the data have been modified manually in the phinx log table.


#10

Okay, it works now. Thanks.