Install passbolt- set up nginx


#1

Hello
I have a problem with the installation of the passbolt, I installed in debian 9 and it happens that when installing instead of putting the hostname, I put the IP of the server where it is running, in this case it is the scaleway.
However when I log in to ip this appears: "Welcome to nginx!
If you see this page, the nginx web server is successfully installed and working. Further configuration is required.
For online documentation and support please refer to nginx.org.
Commercial support is available at nginx.com.
Thank you for using nginx. "

Can someone help me? What is missing and how can I configure it?
Thank you very much who can help.


#2

You need to set up the nginx config to serve passbolt resources out of the passbolt directory. You’ll also need something to actually execute the php, I think php-fpm is one of the more common options.

Here’s my nginx server block.

server {
    listen 443 ssl http2;
    server_name passbolt.example.com;

    root   /PATH/TO/PASSBOLT/webroot;

    index  index.php;

    location / {
        try_files $uri $uri/ /index.php?$args;
    }

    location ~ \.php$ {
        try_files $uri =404;
        include fastcgi_params;
        fastcgi_pass 127.0.0.1:9000;
        fastcgi_index index.php;
        fastcgi_intercept_errors on;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    }
}

#3

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.