Installation problem

Setting up mariadb…

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

Trying to connect to to mariadb with provided credentials…

Failed to enable unit: Unit file php7.2-fpm.service does not exist.

i am new to this and cannot find a solution to this problem during installation. Can some one please help?

Thank you very much.

Hi @razzak, In order to log into mariadb’s root user, your settings require you to be root on the server first. This is a mariadb security feature.

If you do not have php7.2-fpm, maybe you are on Ubuntu Desktop instead of server?

If you have another version of php7 running, maybe the following command will show you:

ps aux | grep php

This will list all processes that have “php” in their name.

Hello Garrett,

thank you for your reply. i solved the ‘php7.2-fpm’ problem by going to the file and changing 7.2 to 7.4.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.