Installation seemingly successful, but doesn't work

Everything seems to install correctly, but pointing my browser to the IP as suggested does not respond. I’m not really sure what the issue is or how to address this as my Ubuntu install was completely fresh. Any guidance or suggestions would be very appreciated, I posted my install log below.

Best,

Jack

Checklist
[x] I have read intro post: About the Installation Issues category
[x] I have read the tutorials, help and searched for similar issues
[x] I provide relevant information about my server (component names and versions, etc.)
[x] I provide a copy of my logs and healthcheck
[ ] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Hi @jack_degug the IP address you are attempting to use appears to be a public IP. Let’s Encrypt SSL certs cannot be created with IP addresses. Only domains. If you do not have a domain you will need to buy one from GoDaddy or some other provider like that.

If you were to provide a local IP address instead, you could run it without certs, and use http, the idea being you have control over the network connections when it’s local.

If this does not help, you will need to explain more what you mean by “does not respond”.

@garrett,

Thanks so much for the response. Basically I keep getting to the… “Installation is almost complete. Please point your browser to http://blah to complete the process”. When I point my browser to the domain, it just hangs and says that connection took too long or timed out. I believe we have a publicly routable domain which I have tried and it seems to experience the same issues. I tried choosing none for the ssl options as well.
Let me know if there’s anything you can do to help, I’d really appreciate it.

Best,

Jack

Hi @jack_degug,

Perhaps you would like to have a look at your firewall settings in the box.
Something might be blocking the connection.

Thanks.

@SKH

Thanks! I tweaked some settings on my firewall and that seemed to be the issue. I really appreciate it, any idea if that may affect any security with passbolt?

Best,

Jack

@jack_degug

Sorry but I can’t really advise as I’m not sure what firewall tweak is done and how your enviroment works.

Anyhow, just allowing http or https traffic thru in the box inself should be fine (it’s supposed to host passbolt anyhow).
Most of the time, your box should be sitting behind another external facing firewall for security.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.