Installation wizard fails when setting up the database tables

Checklist
[x] I have read intro post: About the Installation Issues category
[x] I have read the tutorials, help and searched for similar issues
[x] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[x] I describe the steps I have taken to trouble shoot the problem
[x] I describe the steps on how to reproduce the issue

I have installed passbolt version 2.12.1 on a centOS 7 vm without any problems. The wizard displays that environment and GPG are both configured correctly and SSL is not enabled (I don’t want to use it). I followed the steps of the wizard but at step 7 I get an error: Error! An Internal Error Has Occurred. Debug information is empty.

If I reload the page, only the dead bird appears with the following text: An Internal Error Has Occurred, Not Found The only way to start the wizard again is to reset my server to the snapshot I took before starting the wizard.

I have tried this multiple times. For the database connection I tried to use root, root@localhost and the user I created in the installation progress. I have also checked that mariadb runs on the server and both my database and users exist.

I can’t find any helpful log-files. Is there a possibility to log the sql command that crashes the system?

Hello,

You can check the logs in /logs/error.log in your passbolt installatiion directory on the server.
One reason could be that you used " or ’ in the mysql password, which is known to create some issues (since these are stored as string in the config file).

Best,

Hello remy,

thanks for the tip. I can see that I have a SQL problem, but not what command is tried.

The file shows the following:
2020-05-18 12:15:59 Error: [PDOException] SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘-db COLLATE utf8mb4_unicode_ci’ at line 1 (/var/www/passbolt/vendor/robmorgan/phinx/src/Phinx/Db/Adapter/PdoAdapter.php:168)
Request URL: /install/installation/do_install.json
Referer URL: http://pcs033.goetz.lan/install/installation

2020-05-18 12:22:52 Error: [Cake\Routing\Exception\MissingRouteException] A route matching “/install/installation” could not be found. (/var/www/passbolt/vendor/cakephp/cakephp/src/Routing/RouteCollection.php:216)
Request URL: /install/installation
Referer URL: http://pcs033.goetz.lan/install/account_creation

Did you use a quote in the mariadb password?

I’ve not used the string “or” but I’ve used several special characters. Could that relate to the problem?

I meant the characters ' (single quote) or " (double quote). That could be your issue if you’re using these.

No, I haven’t used those characters

Another issue, that could be related: https://github.com/passbolt/passbolt_api/issues/325

Which version of Mariadb / Mysql are you using?

The package name is: mariadb-server-5.5.65-1.el7.x86_64

Are you using dashes in the database name? That might also be an issue.

This was the problem! After a little fight with mariadb I could finally finish the wizard.

Thanks a lot! :smiley:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.