iOS 17 beta not showing any passwords

I’ve been using this for a while with no issues, about 3 months to be specific, and just recently, on the app, it doesnt show my passwords. It acts as if I dont have any but if I scroll up to refresh, it gives an error saying “Network response decoding failed.” No clue what this means and I haven’t been able to fix it for about a week. Ive tried reinstalling the app, and nothing, iOS updates have come, even rebooted the virtual machine on hosting this, still nothing. But my desktop browser extensions are flawless.

I’m at a loss now :frowning:

Hi @knots

Welcome to the Passbolt Forum!

Can you please share what version of Passbolt server and what version of Passbolt iOS you are using.

When Passbolt updated the iOS app to the latest version, it now requires the Passbolt server to be using at least version 4.0.0.

Hello @duffman,
I just updated to iOS 17 Beta 2 today, my app is on latest which appears to be 1.14.2. I’m not sure how to check the Passbolt server version, doesn’t show in any of the settings that I can see. However I did not think to update the server, I’m using a docker container (not docker-compose)…and I’m not super familiar with docker itself via the cli and not sure how to update it.

Run a health check to see your Passbolt version.

Update Passbolt Docker Container

1 Like

Hello again,

Just an update, I dug into it, looks like I was somehow running either docker-compose as docker or just had the docker image running with a copy of docker-compose. All that to say, I was able to pull the compose image, and restart it. I know it was downloading a new image as it appeared but unfortunately I’m still in the same spot with the same error.

Here’s what my docker compose outputs are looking like after pulling the image and restarting

I just ran a health check, confirmed I am on version 4.0.2, however, i do have a few errors it says which I believe are fine but I dropped them here if you thing otherwise.

Just to inform, I’ve been on iOS 17 Since beta 1 for testing and I haven’t been able to get passwords just on iPhone or iPad. This has been a issue since the beginning of iOS 17 Beta with the same error refreshing “Network response decoding failed”. I did try installing Passbolt app on a older device running the latest iOS 16 and it’s working fine.


@knots i can not see your issue unless I download your uploaded file. Can you please post a screen shot. I have not been able to look at your issue.

you should correct any help issues on health check. “Ok Sparky” just means the Passbolt server is working. iOS needs https security for it to work.


Welcome to the Forum and thank you for your response. The Passbolt developers follow the forum posts and I am sure the issue will be looked into if there is an problem with beta iOS 17. If you are testing beta software you can also post the issues on GitHub for the developers to see.
Can you post any logs to help the community and Passbolt find out what is going on with beta iOS

Are there any links to a Testflight version of the passbolt app or is it all just on the app store?

@ScarsTRF There is the GitHub iOS mobile repo GitHub - passbolt/mobile-passbolt-ios: Passbolt mobile app for iOS

I’ve just upgraded to 17.0 Beta as well and have noticed the same issue. The log which shows the issue is as follows:

Failed to decode bad request response
…resource data refresh failed.

It worked for like two minute after upgrading but then I guess the cache refreshed and it died. I’d like to know if there is any resolution in sight on this as it would be good to continue using this on my iOS device.

Unfortunately I don’t think there’s a work around. Personally for me, I was lucky it was time for a phone upgrade, never really liked 17 anyway, typing was weird. Anyway, it easily set me back to iOS 16.5.1 and it works as expected now. I think the only way for you is to either downgrade or just live with it for now. My guess is that Passbolt sees a beta OS and treats it as a security issue and restricts access to the database.

1 Like

Is anyone able to confirm that this is the case? On beta 3, still not working, and I haven’t seen any source code or issues in the GitHub repository for the iOS app acknowledging there is an issue.

Hi, thanks for reporting! We are aware of some issues on iOS 17 beta however it is still a beta and things are changing and breaking there. We are not actively supporting any beta iOS versions but don’t worry we will fix any potential issues before next iOS release :wink: Application should work correctly on the latest non-beta iOS version.

1 Like