Linking Android Phone App With Account

[X ] I have read intro post: About the Installation Issues category
[ X] I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
[X ] I describe the steps I have taken to trouble shoot the problem
[ X] I describe the steps on how to reproduce the issue

Forgive my n00bness in all of this for the things I haven’t checked if someone would be so kind as to let me know how to obtain that I will gladly provide it. But I’m hoping the issue is something simple.

I personally followed this guide when setting my passbolt up on my personal synology nas at home.

Everything when fairly smoothly without issue, and I have passbolt up and running. I’ve already invited two friends to set their accounts up as well. The issue I’m having is when trying to link my android phone with my account so I can have access to my stuff on the go.

I get the QR code to scan after some fussing (man that thing is hard to get scanned), but then when it ask for the passkey it always tells me mines incorrect. I’ve slowly and I mean painfully slowly typed in my passkey letter for letter, double checked it’s right. Tried changing my pass multiple times, all with the same result while everything else is working flawlessly. I’m not sure if there’s some setting I missed to allow android authentication or something, this is all fairly new to me. But it seems like there’s a handshake issue with just the passkey. I also tried not using QR and doing it manually but nothing I put in the name filed seems to work it gives me an incorrect name formatting error no matter what I put in.

Seem like a great product, just not sure what I’m missing. And again if someone can walk me through how to provide the other needed information I’d be happy to do so as well.


Also forgot to add the phone in question has had the app removed and re-added a few times and it is a Samsung S22 Ultra running the latest version of android.

Hey @StryderX welcome to the forum!

Two things which will help here is the healthcheck from the server and the logs from your android device. Make sure to remove any sensitive data from these.

SSL is a common issue with mobile, either it isn’t enabled or in the case of a self signed cert it isn’t properly imported to the device

I will grab those as soon as I’m home. But seeing as I’ve done nothing with my phone as it wasn’t in the guide I used (which I get), it’s probably that. I did grab the self assigned cert from my NAS and have that file. But where the passbolt guides say to go on Android I can’t find for the life of me lol

Strike that I found where to install them on my phone but I’m not sure I’m grabbing the right things from my NAS. My NAS spits out a .zip file when I extract it with about 11 .pem files. I installed the ones I could but same results. I’ll have to grab that info so I can post it.