Login failed: Gnupg confirmation not available or incomplete

Hello, when I logged in to my pasbolt server today, it prompted "Something went wrong, the sign in failed with the following error:

The GnuPG config for the server is not available or incomplete." The previous logins are normal logins

Hi @chyff please create your issues in the right category (Installation issues) and provide the requested information for this category.

[ ] I have read intro post: About the Installation Issues category
[ ] I have read the tutorials, help and searched for similar issues
[ ] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[ ] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Hello, my centos version is CentOS Linux release 7.4.1708, docker version is 20.10.5, passbolt version is 2.13.5, I use docker run -d --name passbolt --net passbolt_network -p xxx:xxx- p xxx:xx -e DATASOURCES_DEFAULT_HOST=xxx -e DATASOURCES_DEFAULT_PASSWORD=xxx -e DATASOURCES_DEFAULT_USERNAME=xxx -e DATASOURCES_DEFAULT_DATABASE=xxx -e APP_FULL_BASE_URL=https://xxxx passbolt/passbolt and then create a mirror and start the password normally , Due to heavy shutdown of our server every day, the server will restart automatically the next day. I temporarily use docker start passbolt (start image name) to start the database, and it will report Login failed: Gnupg confirmation not available when I log in. or incomplete. If you don’t turn off the server, everything is normal. This problem has been tested 2-3 times.

@chyff most likely the gnupg key is not persisted on the container. By default when you launch the container it will create a server key for you in order to facilitate testing, if I recall correcly, but you actually need to create one and persist it in production. See.

Variable Description Default value
PASSBOLT_GPG_SERVER_KEY_PUBLIC Path to GnuPG public server key /etc/passbolt/gpg/serverkey.asc
PASSBOLT_GPG_SERVER_KEY_PRIVATE Path to GnuPG private server key /etc/passbolt/gpg/serverkey_private.asc

Please check/provide these as well.

Thank you, it has been resolved in this way