Match is Null error. Passbolt not working after restart

#1

I am having the strangest time with my Passbolt. I followed a guide over a year ago to get this set up, and after a few aches and pains got it working.

It has been working fine ever since. But yesterday I had to shut it down the VM it runs on and now that it is restarted I am unable to log in. The error I get is match is null, and it also will no longer send out emails for some reason. I have 30 days worth of backups for this machine, and have restored it to different points and the results are the same always. match is null. I have tried recovering my account, but the email does not get sent to me.

Checking my emails, the last time my passbolt server succesfully sent me an email was 9 months ago.

Going back through the installation process looking for clues, I tried running the healtcheck using

su -c “/var/www/passbolt/app/Console/cake passbolt healthcheck” -s /bin/bash nginx

but got the error below

No passwd entry for user ‘nginx’

At one point I recreated the nginx user, and reset ownership using the commands in the guide

chown -R nginx.nginx /var/www/passbolt/
chmod +w -R /var/www/passbolt/app/tmp
chmod +w /var/www/passbolt/app/webroot/img/public

And the healthcheck gave an error that I believe is causing my login issue:

[FAIL] The server key defined in the app/Config.php is not in the keyring

This is probably information overload here. But I am throwing out as much data as I can. I am still on my original version of passbolt API: v1.6.9 While using Plugin: v2.9.1.

Like I said, it was all working until last night after a reboot of the passbolt VM. Someone please help! There’s a years worth of passwords locked in this thing.

#2

Hello @ghftech,

Passbolt v1 is deprecated since June 2018 (v2 was released a year ago), so I suspect you also had some other issues when managing groups for example.

The best would be for you to make a backup and try an upgrade to v2:
https://help.passbolt.com/hosting/upgrade/ce/upgrade-ce.html

#3

@ghftech I forgot to mention if you upgrade to v2.9.2 for your web extension you may be able to login. (see. Experiencing error "Cannot read property '1' of null" on login )

#4

Upgrading the plugin worked. I will expeditiously get off of the old version of the server. Thank you so much!

closed #5

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.