Parse error in Helm chart deployment.yaml

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

I’m trying to get Passbolt running via. the Helm chart in my Kubernetes cluster.

I keep getting, no matter what i do, a parse-error in the helm chart somewhere in the deployment.yaml.

I have opened a Github issue for this, but i see that the response time there isn’t great - That’s why i’m writing here too.

My values.yaml and more info can be found on the issue: deployment.yaml: error converting YAML to JSON: yaml: line 150: found character that cannot start any token · Issue #83 · passbolt/charts-passbolt · GitHub

I don’t see any other people on here, or anywhere else, with a similar experience. As mentioned in the issue, i do see a recent release in the helm charts repo, which could’ve forsaken the error.

I tried re-downloading the values.yaml from the repo, only supplying minimal configuration for the chart, but still the same error occurs.

Does anyone have any idea how/why this fails?

I see you’ve got

   - secretRef:
       name: passbolt-secrets-env

Could you anonymize and share the content from that? Since it is mentioning a parse error just want to double check that nothing is a bit off there

1 Like

Thank you for replying @clayton

One of the other devs responded on github, and it turns out it originated from a bug in the chart, and a mistake on my part.

Looking forward to using Passbolt :smile:

1 Like