Passbolt 2.5.0 install on Centos 7 stuck on step 7

Good Morning
I am installing passbolt for the first time and used the script.

Server operating system name and version Centos 7.6.1810
Web server name and version nginx 1.12.2-2.el7
Database server name and version mariadb 5.5.60-1.el7_5
Php version PHP 7.2.13
Passbolt version 2.5.0

All went well until I get to step 7.

It just stays on this screen and does not complete.

[ x] I have read intro post: About the Installation Issues category
[ x] I have read the tutorials, help and searched for similar issues
[ x] I provide relevant information about my server (component names and versions, etc.)
[ x] I provide a copy of my logs and healthcheck
[ ] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Hi @kobus

Sorry to hear install is not smooth for you. Could you provide some information from the /var/www/passbolt/logs/error.log /var/log/nginx or php logs?

This is in the error.log:

2018/12/07 09:13:31 [warn] 5721#0: “ssl_stapling” ignored, issuer certificate not found for certificate “/etc/ssl/certs/nginx-selfsigned.crt”
2018/12/07 09:13:31 [warn] 5724#0: “ssl_stapling” ignored, issuer certificate not found for certificate “/etc/ssl/certs/nginx-selfsigned.crt”
2018/12/07 09:13:38 [error] 5727#0: *1 open() “/usr/share/nginx/html/install/system_check” failed (2: No such file or directory), client:, server: _, request: “GET /install/system_check HTTP/1.1”, host: “offiipbt001”, referrer: “http://
2018/12/07 09:13:40 [error] 5727#0: *1 open() “/usr/share/nginx/html/install/system_check” failed (2: No such file or directory), client:, server: _, request: “GET /install/system_check HTTP/1.1”, host: “offiipbt001”, referrer: “http://

No other logs show anything of significance.

Hi again,

I have not been able to reproduce your issue using the latest centos fresh downloaded. Also, the logs you kindly provided do not show any specifics on the problem.

Maybe the output of the healthcheck script could be helpful:

su -c "/var/www/passbolt/bin/cake passbolt healthcheck" -s /bin/bash nginx

This is the result of running the script:
Healthcheck shell…Exception: SQLSTATE[HY000] [1045] Access denied for user ‘’@‘localhost’ (using password: NO) in [/var/www/passbolt/vendor/cakephp/cakephp/src/Database/Driver/PDODriverTrait.php, line 48]

I can see it is not happy with the mysql login details. Where do i enter these so the script can continue? I have entered the details on the page as requested by the installation script.

Can anybody shed some light on this issue please?

@kobus try to follow the instructions from the “install from source code”: to see which steps in the installation failed. So far we are not able to reproduce your issue.

This is very frustrating. I have now tried to reinstall passbolt using the script 4 times and each time the same result.

I have now also tried to install using the src version and it has now stopped at this point:
PHP Warning: Use of undefined constant yes - assumed ‘yes’ (this will throw an Error in a future version of PHP) in /var/www/passbolt/config/passbolt.php on line 68

 ____                  __          ____  
/ __ \____  _____ ____/ /_  ____  / / /_ 

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Running baseline checks, please wait…
Exception: data signing failed in [/var/www/passbolt/src/Utility/Healthchecks/GpgHealthchecks.php, line 304]

this happens when I run:
su -s /bin/bash -c “./bin/cake passbolt install” nginx

Yes is not a valid keyword for configuration, it should be true, false or null.

There is an issue with your server OpenPGP key, which looks like other issues here: Search results for 'cannot be used to encrypt and sign a message' - Passbolt community forum

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.