Passbolt Failed to open dir

I followed the installation word by word but i cant reach the site.
When i do a healthcheck it gives me this:

Any tips?

@dario23 hello, you most likely have a permission issue on the tmp directory or the passbolt directory itself. The installation manual is battle tested so you most likely missed a step if it is not working. This or you should tell us more about your system (OS, webserver, etc.).

Well thank you for the fast reply!

I made sure i did it all correctly checked every letter like a autist is there a way to make the tmp directory permissions correct?

Also im using debian 9 with the webserver settings from the install page.
https://help.passbolt.com/hosting/install/ce/debian-9-stretch.html

Can you list the permissions in your passbolt directory?

ls -la

Normally the tmp permissions are set by composer at the end of the composer install step.

I dont know if you get enough info from this its a limited screenshot.

Alright, make sure you run composer install again and press y when it ask if it should set the permissions.

this is what i get when i do that:

Ok, i’m not sure why you have no permission on that folder (compared to say /logs which looks ok).
You can set it manually:

sudo chmod 770 -R tmp

Okay i changed the permissions and it went well this is what i got after running the install again.

then i did another healthcheck and i got this:

(foto next post)

This is a different issue, linked to the Gnupg keyring
You need to check that:

  • The private key you are using does not use a passphrase (if it is, delete the keyring and start again)
  • The private key and public key are both the www-data keyring
    sudo su -s /bin/bash -c "gpg --list-keys" www-data
  • Gnupg has the correct access rights for this keyring (Gnupg checks that not passbolt).
drwx------ 3 www-data www-data  4096 Sep 17 13:50 .
drwxrwx--- 7 www-data www-data  4096 Jan 25  2018 ..
-rw------- 1 www-data www-data  5191 Jan 25  2018 gpg.conf
drwx------ 2 www-data www-data  4096 Jan 29  2018 private-keys-v1.d
-rw-r--r-- 1 www-data www-data 91639 Jul 11 14:06 pubring.kbx
-rw-r--r-- 1 www-data www-data 90311 Jul 11 14:04 pubring.kbx~
-rw------- 1 www-data www-data   600 Sep 17 13:51 random_seed
srwx------ 1 www-data www-data     0 Sep 17 13:50 S.gpg-agent
srwx------ 1 www-data www-data     0 Sep 17 13:50 S.gpg-agent.browser
srwx------ 1 www-data www-data     0 Sep 17 13:50 S.gpg-agent.extra
srwx------ 1 www-data www-data     0 Sep 17 13:50 S.gpg-agent.ssh
-rw------- 1 www-data www-data  1200 Jan 25  2018 trustdb.gpg

Alright i will do a fresh install since i did put a passphrase on the key.

I will report back in a few hours

I reinstalled the entire thing and it went much better and faster this time.
but i still have some issues. this is the healthcheck:

Hi @dario23 nice to see you are making some progress.

The SSL errors are probably due to the fact that you are using self-signed certificates. You are the best judge of wether your ssl certificate is secure, the indications in passbolt are using simple rules of thumb.

Similarly the status page not being reachable is probably because you do not have an entry in your /etc/hosts. The passbolt.dev domain is not a real one and requires manual entries.

You should turn off debug mode and open registrations though if you are planning on using this instance for something else than testing / demo.

Well at the moment when i go the the ip adress in the browser i get the apache debian default page.

as i understood from the guide i qould be able to read it. i did the installation 3 times now and i get to the point with the 6 errors again. i should be able to reach the site but i cant.

I stopped at step 13 before activating https.
I wanted to demo the site on out work network before getting server space for it but it just wont work.

I get the apache debian default page.

Either your virtual host configuration is not set in /etc/apache2/sites-enabled or you just need to restart the webserver for that configuration to be in effect.

with the 6 errors again

It’s ok if you have some errors for a demo site, like if you choose to not use SSL the healthcheck will show errors but the site will work. For the passbolt.dev not being reachable, it’s most likely a missing /etc/hosts entry.

In a few weeks we will release an installation scripts and a web installer, that should make the whole process easier. In the meantime you can also use the online demo: https://www.passbolt.com/free_trial

The apache 2 service was restarted and this is how my vitual host config is like:

Knipsel

Still nothing.

What do you see with:

ls /etc/apache2/sites-enabled/

Where is the file that are you showing us in your screenshot located?

Show us also the content of /etc/hosts on the client and the server.