Passbolt firefox extension issues

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
Open a login page , enter credentials in passbolt firefox extensions and credentials appear in login page, when you press login there is an error, when I remove a character from the username and password and reenter just the one character i removed it works
I describe the steps on how to reproduce the issue:
on most pages in firefox credentials are pasted with a hidden space/character

Issue started like a few days ago.

In Edge there is no issue.

Hello @The_Michman and welcome to the forum!

What version of the browser extension do you have? I’m having a look right now to see if I can reproduce the problem.

@The_Michman, I forgot to mention.
To know the version of your browser extension you can sign in to your Passbolt account (in the application, not the quickaccess popup), and on the bottom right of the screen there is a heart icon you can hover, you will see the version.

I did a test with the currently available firefox extension (4.5.0) and I can’t reproduce the issue on my side. There is maybe a configuration or something that plays somewhere and provokes your issue but, more information is required to understand.

Does your problem happens on specific websites, or all of them?

Version 4.5.0, let me find a public login page that I have the issue.
It does not happen on all pages.

These are two of the services where i have the issue, I don’t know if you can test it without credentials:

I tried and I can’t reproduce for the moment.

If I understand correctly, when you use the autofill there is an extra space character added in the end of both the username and the password right?

Just to eliminate the easy possibility first, could you check that your corresponding entry in Passbolt is not saved with there extra characters?

Also, which version of Firefox do you have? and is it the standard firefox or the ESR, nightly or dev edition or else?

Regular Firefox, Version 122.0.1
I am not sure there is a space, just making assumption, the login screen does not recognize the characters that passbolt extension pastes there.
there is nothing wrong with the saved credentials, it is the same one that was used before and it worked.
I will re-enter the credentials again directly in passbolt to see if that makes a difference.

Here is a video that may help under stand the issue

Okay I see now.
It’s a known issue, when we fill the information in the forms we also send events on the page to simulate the input as if it was done from a user.

For the story, a community member asked us to change the event used and some forms are now broken. We didn’t see this issue coming, sorry for that. We set a fix that consists in using both the old and the new version of the user input simulation.

For information the fix is already on its way. On chrome the new extension version has been published, on Firefox it’s in review by the firefox team already. We can’t know how much time they need to finish the review as it’s not something with have a hand on.
But, once finished the new version (v4.5.2) will be available with a fix for that.

Sorry for the inconvenience :pray:

[Edit] Once available on Firefox, we’ll keep you in touch to have the fix

Hey @The_Michman :wave:

The firefox extension has been updated to the 4.5.2 and should be available now.
It should fix the problem you have.

1 Like

No trouble at all, you do a great job.

Can confirm that version 4.5.2 resolved the issue, thank you very much.