Passbolt showing default NGINX page (duplicate config files)

Checklist
I have read intro post: community[dot]passbolt[dot]com/t/about-the-installation-issues-category/12
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck - unable to access.
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

Hi there!

I have followed the steps on the wiki, regarding installing PassBolt on Ubuntu.

Server Specs:

Dell Optiplex 745 running 4GB of Ram and some sort of Dell Pentium. Running Ubuntu Server 22.04.01 LTS.

Once I get to the stage where you must go to your browser and continue setup… I just get taken to the default NGINX page?

I’m using a cloud flare tunnel to do the domain side of things as my Virgin broadband router won’t allow port forwarding and I don’t control what router we use as i live in rented accommodation and I’m not the landlord.

Here’s some screenshots to help explain:


Does anyone have any idea how to access PassBolt?

Hi @Shifty the screenshots are not showing for me. I’m assuming you are installing with the Ubuntu package, correct?

Did you have NGINX installed before the package install? Are you serving any other sites from your NGINX? It seems that the default NGINX server block is getting in the way of passbolt configuration for NGINX. To run a test of the config for NGINX: sudo nginx -t. If there are errors that will help know what to fix.

There may be duplicate default servers in the NGINX *.conf files.

And in the chance the files are OK but the service didn’t reload properly you can do sudo service nginx reload.

Your website is doing something to the screenshots. I can’t just upload them as images.

Nginx was installed by the ubuntu install script… when running command:

sudo apt install passbolt-ce-server

it was a completely fresh ‘blank’ install of ubuntu

Hi,

I tried to download your images but they are hosted on google and got a 403 forbidden response so I guess the access is restricted.

On your Ubuntu server, you should have on /etc/nginx/sites-enabled folder only one nginx-passbolt.conf file. If you have a default.conf file, please delete it and reload nginx:

sudo systemctl reload nginx.service

Best,

that was the issue, thanks.

Now i can’t get SSL to work, haha. i set it to automatically set it up, but it isn’t?

Possibly got removed with the duplicate file? Passbolt Help | Auto configure HTTPS with Let's Encrypt on Debian and Ubuntu

You can run the configuration again if needed.

chrome_tRZ1zrAFct

In the nginx-passbolt.conf you can change this:
server_name _;
to:
server_name pvault.icu;

Nice. It all works now, thank you!

Maybe you should add these to the troubleshooting FAQ? I’ve always had these issues everytime i tried to install passbolt. Which ultimately ended up in me giving up on the project.

1 Like

It’s a good idea. It is intended to install and work without problems, but it’s still a common problem. Would you like to suggest where you think it should show up on the help site? We can definitely consider adding it.

Maybe here?

  • Having issues with SMTP now. Got to the installation stage and then it refreshed and asked me to login. Not receiving an email to verify. :sweat:

Edit: Looked at passbolt.php and all of the SMTP credentials are correct.

Hi @Shifty,

Do you mind opening a new topic with the title:

Having issues with SMTP, even though SMTP credentials are correct.

Would gladly assist, although this thread has been solved with the issue being “Passbolt showing default NGINX page”

Regards,
Bond

1 Like

I’d rather not spam the forum…

To be honest, I can’t be bothered to keep working on all these issues.

It’s not spamming the forum, you have a different problem that does not relate to “Passbolt showing default NGINX page”.

Do not give up so easily, theses issues are minor once sorted. You would have no problems at all.

Regards,
Bond

That doesn’t give me a reason to create multiple pointless topics.

Hello @Shifty, jamesbond is right it’s better to create a new issue. Same symptoms doesn’t always mean it’s the same root cause.

I never said this.

Same symptoms doesn’t always mean it’s the same root cause.

@Shifty I’ll be closing the thread to help keep things organized. Thanks @JamesBond and @remy.