After installing Passbolt, the Nginx test page is shown


I just installed Passbolt following this link (Passbolt Help | Install Passbolt CE on Ubuntu 22.04).

After installing and setting it up, I went to the IP address and it redirected me to the default Nginx webpage. I followed this topic (Passbolt showing default NGINX page (duplicate config files) - #3 by Shifty), but doing that doesn’t work because it just gives me an generic connection error loading page afterwards.

When I browse to it does guide me through the installation, but afterwards I once again get an generic connection error page and I have no idea what URL I have to use to get to the Passbolt dashboard.

Funny thing is, it did work right out of the box, once, but I had to revert the virtual machine because I messed up, so I repeated the exact same steps as I did before and now I keep getting that Nginx default webpage despite the steps begin the same. What Am I doing wrong?

Thanks in advance.


hey @Salazar welcome to the forum. What do you have set for fullBaseUrl in your /etc/passbolt/passbolt.php file?

Hi clayton,

The full base Url is: ‘

Alright, since is cloudflare’s DNS name server how are you hosting this instance? Like is this a fully airgapped environment?

I’m sorry. I replaced my IP address with a random one. Not sure why though… The full base URL is: ‘

No worries, I just thought we were going to have to dig into some fun networking stuff.

Just to be clear here, you had it working, had to revert to a pre-install/completely fresh state, and then you can do the command line install but when following the

   Well done! Visit to finish installation 

instructions you are given the default nginx page?

Also, you checked in /etc/nginx/sites-enabled and you don’t have a default.conf there, just the nginx-passbolt.conf file, correct?

Yes. I reverted it back to a fresh install. I followed the instructions and it redirected me to the standard Nginx testpage. I tried to delete the default config file, so that nginx-passbolt.conf is the only file in that directory, but then nothing is loaded, just an generic connection error and that the page could not be loaded.

To be honest, I did get this error every time I try to install Passbolt, but didn’t think much of it, because despite the error, everything did seem to work, once.

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I also had issues with the application Dialog, but I fixed that with:

app install dialog

Can those things be related to my issue?

Yea having an error there is likely contributing to this. Do you have any more info on this or was that the only error message you saw?

I’ll collect all the errors that I came across and post them tomorrow.


I’ve attached the error code that I’m getting. I reverted the VM back to a fresh state and started again. Previously I used an IP address for the domain, so I got the error that LetsEncrypt cannot create a certificate based on an IP address, but using an actual domain name (which I can only resolve locally), gives this error.

Note: I started the installation again and once again I’m getting the default Nginx webpage.

Thanks! That makes sense for why you are getting this page.

The auto option which uses Let’s Encrypt requires a valid domain name which is accessible to the outside internet. As seen in their documentation.

Based on that you’ll want to revert again and either provision your own certs and use the manual option or go with none. It doesn’t sound like the auto will be an option for you with your current set up


I’ll try that option and let you know. Thanks so far!

I tried your solution and it worked! Could’ve figured that out on my own, but didn’t…
Anyway, thanks so much for the fast help, clayton!

1 Like