Passbolt web Interface is broken

Checklist
[ ] I have read intro post: About the Installation Issues category
[ ] I have read the tutorials, help and searched for similar issues
[ ] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[ ] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

I’ve recently enabled SSL on Passbolt server. After updating NGIX and Passnolt config it broke the web interface of Passbolt, see the image below how it looks.

I’ve made the following changes to /etc/nginx/conf.d/passbolt.conf

server {
 listen 443;
 server_name passwords.sbs.local;
 ssl on;
 ssl_certificate     /etc/ssl/certs/passbolt.crt;
 ssl_certificate_key /etc/ssl/certs/passbolt.key;
 ssl_protocols TLSv1.2;
 ssl_prefer_server_ciphers on;
 ssl_ciphers ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS;
 ssl_session_tickets off;
 root /var/www/passbolt;
# X-Frame-Options is to prevent from clickJacking attack
 add_header X-Frame-Options SAMEORIGIN;
#  disable content-type sniffing on some browsers.
 add_header X-Content-Type-Options nosniff;
# This header enables the Cross-site scripting (XSS) filter
 add_header X-XSS-Protection "1; mode=block";
# This will enforce HTTP browsing into HTTPS and avoid ssl stripping attack
 add_header Strict-Transport-Security "max-age=31536000; includeSubdomains;";
location / {
   try_files $uri $uri/ /index.php?$args;
   index index.php;
 }
location ~ .php$ {
   fastcgi_index           index.php;
   fastcgi_pass            127.0.0.1:9000;
   fastcgi_split_path_info ^(.+.php)(.+)$;
   include                 fastcgi_params;
   fastcgi_param           SCRIPT_FILENAME $document_root$fastcgi_script_name;
   fastcgi_param           SERVER_NAME $http_host;
 }
location ~* .(jpe?g|woff|woff2|ttf|gif|png|bmp|ico|css|js|json|pdf|zip|htm|html|docx?|xlsx?|pptx?|txt|wav|swf|svg|avi|mpd)$ {
   access_log off;
   log_not_found off;
   try_files $uri /app/webroot/$uri /index.php?$args;
 }
}

I’ve also made the changes to the following file /var/www/passbolt/config/passbolt.php

fullBaseUrl’ => ‘https://passwords.sbs.local

I don’t know if anything else needs to be updated. I’ve restarted all the services as well.

Hi @ahmedmomin,

It appears you are directing requests for css files to the wrong location so the styling (and other things) is broken. Double check /app/webroot to make sure that’s correct. Maybe it should be /var/www/passbolt/webroot?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.