Passbot on CentOS fails database configuration

Brand new installation on a CentOS box. I’m following instructions to stand up Passbot. I am not able to configure SSL at this time, using http for now. At the database configuration, I get stuck as I’m always getting the error:
A connection could not be established with the credentials provided. Please verify the settings.

Checklist
[X ] I have read intro post: About the Installation Issues category
[X ] I have read the tutorials, help and searched for similar issues
[X ] I provide relevant information about my server (component names and versions, etc.)

– Server operating system name and version: CentOS Linux release 7.6.1810 (Core)
– Web server name and version: nginx version: nginx/1.16.1
– Database server name and version:
| @@version |
±----------------+
| 10.3.35-MariaDB |
±----------------+

– Php version:

PHP 7.4.30 (cli) (built: Jun 7 2022 08:38:19) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies

– Passbolt version: latest

[X ] I provide a copy of my logs and healthcheck

Note: I’m not sure what logs you need

14:01:48 # ./bin/cake passbolt healthcheck

 ____                  __          ____
/ __ \____  _____ ____/ /_  ____  / / /_

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/
/ _
,
/
//./_//__/

Open source password manager for teams

Healthcheck shell…Notice Error: Undefined index: message
In [/usr/share/php/passbolt/src/Utility/Healthchecks/DatabaseHealthchecks.php, line 72]

2022-06-30 18:01:58 notice: Notice (8): Undefined index: message in [/usr/share/php/passbolt/src/Utility/Healthchecks/DatabaseHealthchecks.php, line 72]
Exception: Connection to Mysql could not be established: SQLSTATE[HY000] [1045] Access denied for user ‘’@‘localhost’ (using password: NO)
In [/usr/share/php/passbolt/vendor/cakephp/cakephp/src/Database/Driver.php, line 133]

[X ] I describe the steps I have taken to trouble shoot the problem

Change passbot username and password
Connect using new passbot username and password locally (works)
Check connectivity from another Linux box, I get the following error:

Trying 172.24.100.24…
telnet: connect to address 172.24.100.24: No route to host

[X ] I describe the steps on how to reproduce the issue

Install Passbot
Launch browser
Navigate to the passbot webserver
Enter details in database configuration
See the error:

A connection could not be established with the credentials provided. Please verify the settings.

Hi @fabiogil

Can you confirm these things for clarity:

When you say

do you mean the db user? That you are logging into the local db?

Hi @garrett

Answer to all questions is ‘Yes’

db is on local server and I am using official instructions and I changed the db username and password

@fabiogil OK great.

Did you set a password for the root db user, and then choose option 1 which created another user with a password and took you to the healthcheck?

Or, did you choose option 2 for using an existing db?

@garrett
I chose option 1 (local mariadb server) I did set a password for the root db user and passbolt username and password. It didn’t take me to the healthcheck page. I was given the option to install Haveged.

@fabiogil It seems you entered in wrong information during configuration. I would start the configuration process again.
sudo /usr/local/bin/passbolt-configure

The error you showed says the app is trying to log in to the db with a user called @localhost with no password, and access is denied. Make sure you are running the configuration with sudo. But this implies it’s not trying to access as a user at all. It should at least be root@localhost.

Also make sure you have set up mariadb properly… if your default mariadb installation has been set up so root has a password, make sure to enter that root password into the Passbolt configuration. Passbolt just needs root access to the db during the configuration, and will create the passbolt db user and passbolt db table for you if you choose option 1.

If any of that worked, you should find a user in the db that was created for you along with a new table.

Try it again, and see what happens.