Removed Passbolt ce server, reinstalled, still getting old login page

[X ] I have read intro post: About the Installation Issues category
[ X] I have read the tutorials, help and searched for similar issues
[ X] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[X ] I describe the steps I have taken to trouble shoot the problem
[ X] I describe the steps on how to reproduce the issue


Hi trying to get back to a fresh install here but still seeing my login page form the last install.

Removed ce server:
sudo dnf remove passbolt-ce-server


sudo dnf install passbolt-ce-server

Ran configure agin and provided unique db name, db user name, but non-unique hostname (The IP of the server oin which passbolt ce server lives):
sudo /usr/local/bin/passbolt-configure

And then I go to the passbolt front page at the host IP and still
see the image above (from the previous install). Email was not configured properly so I cant use it.

Config file appears unconfigured (but as I new user, it wouldnt let me post the contents 0_o :
sudo vi /usr/share/php/passbolt/plugins/Passbolt/WebInstaller/templates/Config/passbolt.php

Also here is the DB:

MariaDB [(none)]> show databases;
| Database |
| information_schema |
| mysql |
| passboltdb |
| passboltdb1 |
| passboltdb2 |
| performance_schema |

Ok so theres 2 passbolt.php. The working config one is at:

I moved that passbotl.php out of there and removed ce server again

On running, configure:
sudo /usr/local/bin/passbolt-configure

and having provided the same root DB password for every attempt, I noticed the configure script reports it cant get into the MariaDB…

Setting up mariadb…

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

Trying to connect to to mariadb with provided credentials…

Opening ports 80 and 443 on firewall

Warning: ALREADY_ENABLED: http
Warning: ALREADY_ENABLED: https

and as you can see it merrily pushes forward regardless of the root DB problem - but this time and only this time, theres no web page! I also note the passbolt.php is empty…
So is passbolt-configure not able to write the passbolt.php this time, now that I manually removed the old one?

I’m going to uninstall and delete the /etc/passbolt directory this time. OK starting over.

Hi @pasbbolting :wave: and welcome to passbolt comunity forum :handshake:

I tried to reproduce your issue, and as you notified, /etc/passbolt/passbolt.php configuration file is not removed when passbolt-ce-server package is removed.

When you install passbolt for the very first time, this configuration file doesn’t exists and you have to answer to some questions throught the web installer.

This web installer is not displayed when passbolt configuration file exists, as it is created by web installer. So you have to delete /etc/passbolt/passbolt.php configuration file to restart configuration from the beggining.

Let me know if you have further questions.


1 Like

Regarding this error, when you remove passbolt-ce-server package, if you want to restart from scratch, you should ensure mariadb-* packages are removed too, and delete /var/lib/mysql folder who contains your configured passbolt databases (only if, of course, you only have passbolt database). This folder is not deleted while removing mariadb-server package.

During passbolt-configure script, you are asked for defining a password for root user. This will be reset if you delete /var/lib/mysql.


1 Like

Just to clarify, passbolt.php is not written by passbolt-configure script, who configure database and nginx web server only. passbolt.php is generated by passbolt web installer.


1 Like

OK [update 1]- I have tried removing passbolt.php and then install, configure. No web endpoint response.

[update 2]
So this time I remove the /etc/passbolt directory

Looks like mariadb uninstalls perfectly when dnf remove passbolt-ce-server:

No match for argument: mariadb-*
No packages marked for removal.
Dependencies resolved.
Nothing to do.

[update 3]
So it looks to me like when wiping removing, you can to remove the /etc/passbolt directory for sure

Cool, so you finally installed passbolt succesfully ? Just for curiosity, which operating system are you using ?


I had success before but then I made a whoopsie on the config after web launch.

But yeah Im back in action.

Im using Rocky 8.5

1 Like