Restoring after fresh dnf install

[X ] I have read intro post: About the Installation Issues category
[ X] I have read the tutorials, help and searched for similar issues
[ X] I provide relevant information about my server (component names and versions, etc.)
[ X] I describe the steps I have taken to trouble shoot the problem
[? I guess ] I describe the steps on how to reproduce the issue

Rocky 8.5 - Passbolt CE latest (Nov.24 2022)

I just got my SQL dump and passbolt.php backups onto the system, ready to …copy somewhere and import whatever and completed

sudo dnf install passbolt-ce-server

Now maybe I missed it… but I can’t find the Really-Dumbies-Guide to Restoring from backup.
I followed the backup guide to backup which just prescribes to dump your sql and grab a copy of your passbolt.php.

So should I now run

sudo /usr/local/bin/passbolt-configure

and then stop the passbolt service or whatever
and copy the php file in, and re-un-dump the mysql
and thats it??

This page is the one I think you are looking for. Toward the bottom are steps to migrate (which is restoring from backup).

1 Like

One more issue actually. Since we have this in production still… how can I restore to a non-SSL instance? Upon restore, I see that its configured for its certificate but we’re restoring to a different hostname.

Its just a test restore to make sure our data is still intact.

The registration of each user will be based on the domain, so any change in the domain will cause a prompt to register again… since you are creating a new test instance this is not a big deal but just a heads up.

You’ll need to change the config in /etc/passbolt/passbolt.php to match the new domain. Also, the NGINX listener may need to have the new domain name and maybe cert paths/cert names depending on your setup.

With rpm package, you just have to execute again the sudo /usr/local/bin/passbolt-configure has explained in the doc, and in case of domain change, the script will update both /etc/passbolt/passbolt.php file, nginx config files and reload nginx.

Just FYI :slight_smile:

We have a “This key does not match any account” situation.

OK I got quite far with this and now seeing this error that our private keys don’t work on this new test instance.
I copied in our passbolt php and imported the DB.
If I log in as a new user, like create a new user, I can see all our old users in the web GUI but of course the passwords arent there. OK right… however…

I reimported our php and mysql db again and ran this again as required:

sudo -H -u nginx /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt migrate"

I tried the prod “master account” login with that exact email that was used during setup of our working prod passbolt, with that private key we carefully stowed away in case this thing blows up. Fail.
I also try logging it in with my account and my private key.

domain name and everything else is the same, cert is happy etc.

In any case, its been “this key does not match any account”

Important note is that we did s few test recoveries with these accounts before.

Do you have two instances of passbolt running on the same machine, or maybe the settings are incorrect and this is directing to the wrong db? Unless your key is copied/modified in error, this error typically means what it says. The key doesn’t work with the db records of the user public keys, or it’s not in the keyring: This key doesn’t match any account

Also, since this thread is solved, make sure to tag me or someone else who has helped so we see the message and can help.

Thank you for your helps

1 Like