[SOLVED] Passbolt server shows "Could not verify server key. " message after kreatin first user

I have successfuly installed Passbolt server on Ubuntu16.04 server and created user admin from the command line, but after setting password for admin, it shows me "Could not verify server key. " message, as you can see on the picture below.
Also, this happens on both Chrome and Mozilla web browsers. Anyone has suggestion?

Could you paste the result of the healthcheck?
Something like:

su -s /bin/bash -c "app/Console/cake passbolt healthcheck" www-data

Or if you are running the v2:

su -s /bin/bash -c "./bin/cake passbolt healthcheck" www-data

Ok, i tried to ran the healthcheck, it gives me permission denied error.
The full output is:

Healthcheck shell.Error: RecursiveDirectoryIterator::__construct(/var/www/passbolt/app/webroot/img/public/): failed to open dir: Permission denied
#0 /var/www/passbolt/app/Lib/Healthchecks.php(54): RecursiveDirectoryIterator->__construct(’/var/www/passbo…’)
#1 /var/www/passbolt/app/Lib/Healthchecks.php(43): Healthchecks::_checkRecursiveDirectoryWritable(’/var/www/passbo…’)
#2 /var/www/passbolt/app/Console/Command/Task/HealthcheckTask.php(136): Healthchecks::environment()
#3 /var/www/passbolt/lib/Cake/Console/Shell.php(458): HealthcheckTask->execute()
#4 /var/www/passbolt/lib/Cake/Console/Shell.php(455): Shell->runCommand(‘execute’, Array)
#5 /var/www/passbolt/lib/Cake/Console/ShellDispatcher.php(219): Shell->runCommand(‘Healthcheck’, Array)
#6 /var/www/passbolt/lib/Cake/Console/ShellDispatcher.php(66): ShellDispatcher->dispatch()
#7 /var/www/passbolt/app/Console/cake.php(52): ShellDispatcher::run(Array)
#8 {main}

Which webserver are you using? If you are using nginx you need to replace www-data by nginx.

I am using apache, now I have changed the owner and the output is :slight_smile:

The gpg issue should be solved if you import the private key in your keyring manually.

$ sudo su -s /bin/bash -c "gpg2 --import-key /var/www/passbolt_api/app/Config/gpg/private.key" www-data


Thank you, i tried it but it still shows the same message. Maybe it’ s because of bad configuration in my default-ssl.conf file?

“Could not verify server key” is not related to HTTPS configuration.
From experience it means that the key is not accessible by php to encrypt and sign. This means that either the private key is not in the keyring or you are using the fingerprint of another key.

Could you list the keys and see if the secret key is present?

$ sudo su -s /bin/bash -c "gpg2 --list-secret-keys" www-data
$ sudo su -s /bin/bash -c "gpg2 --list-keys" www-data

Check also the logs for cue in the application folder in logs/error.log

I solved this issue, I created key with passphrase, which is not supported, now when i login it gets stuck
on loading page, i entered my IP address in core.php file and I have put https, do You have any suggestions?

@Miodragl that’s probably an issue with your fullbaseurl and the main passbolt script not being reachable, could you open the console (right click > inspect element > network) to see what’s wrong?

Everything returns status 200, except config.json and notification.json
they failed.

Could you paste the error messages from the logs?

passbolt.js:8 GET https://xxx.xxx.xxx.xxjs/app/config/config.json net::ERR_CONNECTION_TIMED_OUT

passbolt.js:8 GET https://xxx.xxx.xxx.xxx/js/app/config/notification.json net::ERR_CONNECTION_TIMED_OUT

I meant the logs from the server, in app/tmp/logs on v1.x.

Could it be that the port is missing in your fullbase url?

i just added my ip addres, i didnt add port 443?
/app/tmp/logs is empty

No normally that’s not needed. I mean the address js/app/config/config.json is correct, so I thought the problem is in the first part of the url.

If the log are empty it means this url is not reachable, so that’s not something to do with passbolt, so i’m thinking it’s the config of your webserver / url rewriting not setup correctly. Which is strange since the rest if working…

Could you try to clean your browser cache.

OK, my virtual machine is vagrant machine, and i enabled port forwarding from localhost (8082 fom local to 443 on virtual machine) because cant access my virtual machine ip address diretly, perheps that could be the problem?