[SOLVED] Test email working, recover email not working, user creation email working

Hello community !

I’m having some troubles after migrating a passbolt instance (testing backup / restore process)

[x] I have read intro post: About the Installation Issues category
[x] I have read the tutorials, help and searched for similar issues
[x] I provide relevant information about my server (component names and versions, etc.)
[x] I provide a copy of my logs and healthcheck
[x] I describe the steps I have taken to trouble shoot the problem
[x] I describe the steps on how to reproduce the issue

Server infos :

  • PHP 7.3.27-1~deb10u1
  • mysql Ver 15.1 Distrib 10.3.27-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2
  • Debian 10 Distro (Passbolt Installed through passbolt deb package)
  • nginx version: nginx/1.14.2
  • Passbolt CE 3.1.0
  • Cakephp 3.9.5

HealthCheck :

Troubleshooting steps :

  • SMTP Server OK (IP Whitelist, Gmail relay)
  • Test email OK (Through Web interface and CLI)
  • Passbolt reinstall.
  • Passbolt.php adjustments → Added ‘client’ => ‘<server_ip>’, in SMTP config after looking at passbolt forum.
  • Still not working :frowning:

Reproduce issue :

  • Install Passbolt through debian 10 documentation of Passbolt.
  • Restore an existing passbolt database in mysql (migrating another passbolt instance)
  • Restore avatar and config
  • Post install steps (Server name, smtp config)
  • Send test e-mail from GUI : WORKING !
  • Attempt to recover an existing account of the DB with /users/recover URL
  • User found in DB, passbolt says " Check your mailbox!"
  • No email received

I’ve also trie to send a test mail using CLI, it’s working properly.
I’ve also added an admin user using CLI, and received an email.

It seems that the recover email sending is not working.

Any ideas ?

@brawcks can you check under “administration > email notifications” if the “register and recovery” toggle button are on?

1 Like

Oh… I’m very very bad, i litterally not checked it … @remy jackpot, i thought (and not verified, bad play from me) it would be activated by default.

This was the problem, thanks a lot !

No problem, you made a good description of your issue, so it was easy to find out what’s wrong :slight_smile:

1 Like