SSO Administration page is blank using Firefox (Pro 3.9.0-1-pro Docker)

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

After switching to the latest pro Image (3.9.0-1-pro @ Docker Hub ) and activating the plugin in the docker-compose.yaml by setting ENV-Variable PASSBOLT_PLUGINS_SSO_ENABLED: 1 (as described in (SSO How To) the the SSO Section is shown in the Administration Navigation but when accessing it the page is blank (see screenshots).

The log (/var/logs/passbolt/error.log (redirected to stderr) → docker log of passbolt-container) only shows http200 Codes for successfully loading the page :frowning:

Anyone else got this issue or got the sso section running in a docker env?


Can you execute:
su -s /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt healthcheck" www-data
And check for the database if there is no migration missing.

Also do not hesitate since you are a pro user to use the support (


hi @max
thanks for the hint - tried it and healthcheck says all’s fine.
I ran the migrations manually though - no improvement.

I’ll get in touch with the support and get back here with a solution (at least I hope so :wink: )

Neverthess, if someone got an idea/solution/input on this - here we go!

Ok, so most likely there is a issue with the browser extension.
Do you see any error in the browser extension console?

This is different from the previous console.

  • If you are using Google Chrome can you please go to: chrome://extensions
  • Activate the Developer mode in the top right corner
  • Look for the Passbolt card and click details button
  • Look for the Inspect views and the index.html link
  • A new window will appear this is the debugger of the browser extension
  • Go to network tab
  • Try to reproduce the error
  • Export logs by clicking the down arrow

  • On Firefox, you can go to: about:debugging#/runtime/this-firefox
  • locate Passbolt and click Inspect
  • A new tab for the console of the browser extension will appear.
  • Go to the network tab
  • try to reproduce the error
  • Export logs by clicking right on the logs and select “Save all As HAR”

HAR files are text files in json format. They contain sensitive data such as your Passbolt main url or your browser version. You can’t check by opening them in a text editor.

You can transmit it to


1 Like

@max Thanks again for the hint :wink:
I tried it using Firefox which led to the described behavior : blank page.
When using Chrome it works well! I set SSO up and it works!

But it seems like FF not beeing supported at all. Even reinstalling the plugin didn’t help.
I also can’t use SSO in FF since it’s not offered on Login page :man_shrugging:
Maybe the FF Plugin needs to be updated …

Thanks for your support @max

1 Like

Hello @plutzo, passbolt v3.9 is still pending review on Firefox store, SSO require v3.9 to work. :pray:

1 Like

@remy Thanks for the info! Then we’ll just wait :slight_smile: