This key doesn't match any account. Error when trying to recover account

Hi all,

So after a server update, it seemed that there were some unintentional changes. And unfortunately backups weren’t working. Go figure. Lessons learnt there.

Anyway, so randomly, well not so after some investigation. Our public/private key had expired. Due to following instructions for setup back in 2017. Anyway, so we extended the expired public key etc to no longer expire. Removed the .gnupg directory from the web servers home directory, and reinitialized it with the new key without the expiry.

Anyway, now I can’t recover my account. I can initiate my account recovery, but I can’t actually recover my account. When I select my correct private key, it doesn’t recognize the account.

Any hints? Or is it possible to just create a new account and reassign everything to it?

Hello @dorient,

Did you follow this process to replace your expired key ?

  1. Ensure your replaced the old gpg keys in /var/www/passbolt/config/gpg with the new ones (private and public).
  2. Remove the webserver gnupg keyring
    rm -fr /home/www-data/.gnupg
    /home/www-data/.gnupg could vary regarding your environment.
  3. Import the new gpg key in the webserver gnupg keyring
    su -s /bin/bash -c “gpg --import /var/www/passbolt/config/gpg/serverkey_private.asc” www-data

If you follow the same process, and it still not working;
Send us an email to, we’ll help you from there.

Best regards,

@cedric yup sure did!

I extended expire to null
Exported private/public key
Reconfigured Passbolt
Then followed the process outlined above
Rebooted just because

Still not working. Will send an email.

Hello @dorient,

Ok, we are waiting for your email.

Best regards,

We had the same issue. I believe the “This key doesn’t match any account.” is a bug in the Chrome extension (I have at least one report that the Firefox extension wasn’t affected by this). As far as I understand it. the extension is supposed to query the server whether the key belongs to a known user in the database, but as far as I could tell, it didn’t actually query the server. There was no request in the Chrome inspector, and no request in the server’s access.log.

The workaround is to reinstall the extension; the recovery worked afterwards. Make sure you have your passbolt_private.asc key backup ready before you remove the extension, because uninstalling the extension without having a backup will make you lose your private key.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.