This key doesn't match any account error

Ok, I just updated my passbolt installation to the latest docker image. Previously, I created a volume to store all the GPG keys that I let passbolt generate. On first login, my plugin said that the Serverkey didn’t match, I then tried to reinstall the plugin, however, the Serverkey shown during the install make me think that it was the time to setup a proper key for this server and generate one with the right owner. So I did, and I changed it in the volume (erasing the old one at the same time). Now, the key is properly shown, and everything seems fine, but when I try to recover my account, I get the “This key doesn’t match any account” error. I’m starting to realize that I may have lost all my passwords because I lost the previous server key, please tell me I’m wrong.

If that’s the case though is there a way to recover the passwords of a user from the database with his key, or the server key is also needed for that ?


Don’t bother, I tried and yes, I can just decrypt the PGP blobs that are stored in the Database.

EDIT: Actually I managed to make passbolt working again by adding my user’s private keys to the keyring of the www-data user in the container. That’s the first time I need to do that … I have also wrong healthchecks concerning gnupg. Anyway this thing seems solved at least.

Does that means that I will need to add those keys back to the keyring each time I update passbolt now ?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.