Trying to recover account but stuck in download extension loop

Checklist
I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

I have restored my PostgreSQL backup in Postgres container using psql, and restored passbolt container using image backup, but after receiving the recovery URL over the email it got stuck in the download extension page loop…

Hi @nik and welcome to the forum!
Please, can you provide some logs and configuration/healthcheck to check what can be failing?
Don’t forget to change sensitive data

1 Like

Hi @Termindiego25 thank you for your respose.
here I’m attaching healthcheck logs “account recovery over Firefox browser”.
healthcheck.

Container logs.

hi @Termindiego25 please suggest me a solution

Hey @nik

It looks like you got some issues with the GPG keys of your server.
When you said you restored the DB, did you also change anything on the server side?
under /etc/passbolt/passbolt.php you have some references to serverKey

Did you set the fingerprint in the passbolt.php?
If so, you need to precise the public and private key path corresponding to that fingerprint

Hi @nik, as Max said, I suggest you try to solve the fails on your healthcheck, especially the ones about GPG key.
You can search on the FAQ or documentation for some guides to troubleshoot or solve that

i dont have /etc/passbolt/passbolt.php inside i have /etc/passbolt/passbolt.default.php inside passbolt container.
and i havent set the fingerprint in the passbolt.default.php.

Are you using docker?

If so did you set:
PASSBOLT_GPG_SERVER_KEY_FINGERPRINT
PASSBOLT_GPG_SERVER_KEY_PUBLIC
PASSBOLT_GPG_SERVER_KEY_PRIVATE
?

@max no i havent set this variables in my docker-compose file.
this is the log when i try to recover my id.

and this env I added
APP_FULL_BASE_URL:
DATASOURCES_DEFAULT_HOST: passbolt
DATASOURCES_DEFAULT_DRIVER: Cake\Database\Driver\Postgres
DATASOURCES_DEFAULT_PORT:
DATASOURCES_DEFAULT_ENCODING: ‘utf8’
DATASOURCES_DEFAULT_USERNAME:
DATASOURCES_DEFAULT_PASSWORD:
DATASOURCES_DEFAULT_DATABASE:
EMAIL_TRANSPORT_DEFAULT_HOST:
EMAIL_TRANSPORT_DEFAULT_PORT:
EMAIL_TRANSPORT_DEFAULT_USERNAME:
EMAIL_TRANSPORT_DEFAULT_PASSWORD:
EMAIL_TRANSPORT_DEFAULT_TLS: “true”

If you have a backup of the database,

can you connect to your database and do a
DELETE FROM organization_settings WHERE property='smtp';

And start again your recovery process.

The problem here is that you didnt keep a backup of the gpg volume and it was containing your server GPG key pairs.

Those keys are used (among other things) to encrypt some setting such as the SMTP in database.

That is why you have those error.

1 Like

Hey @max Thank you for your support.
I ran DELETE FROM organization_settings WHERE property=‘smtp’; query in db and restarted passbolt container, SMTP and download extension issue is solved.

1 Like

We created a ticket to avoid this scenario thanks!

1 Like