Unable to complete system setup

I install passbolt in the console, then go to the browser.
I configure all fields (I check the mail, the letter arrives).
When I press the button to apply the settings made, the “circle” turns endlessly, I waited for several hours. I tried it on two different systems: Ubuntu server 22.04; CentOS 7 (7.9…).
When I click on the button where the circle is spinning, I go to the page to restore my account, enter my username (specified when filling in the parameters). The system writes that it has sent a recovery link to the mail, but nothing comes to the mail… Let me remind you that when specifying the settings of the mail server, I checked, test emails are coming.

I have already installed Passbolt before and there were no such problems. I don’t know where else to look.
Help me figure it out, please.

Hi @Mr.Toad Can you provide errors from the logs or a healthcheck?

What are the specs for the machine on which you are installing? Were there any warnings during the package install process (console)?

Hi @garrett!
Deploying on a Hyper-V virtual machine.
By errors:
cat /var/log/passbolt/error.log

2023-04-08 12:30:32 error: [Cake\Routing\Exception\MissingRouteException] A route matching "/robots.txt" could not be found. in /usr/share/php/passbolt/vendor/cakephp/cakephp/src/Routing/RouteCollection.php on line 197
Request URL: /robots.txt
Client IP:

cat /var/log/passbolt/debug.log

2023-04-07 11:03:22 info: SMTP Settings were detected in env.

My installation stops at the penultimate point (the wheel turns)

This does occasionally happen. It’s not a specific problem and it’s unexpected. That normally means you should attempt a fresh install. In the past we’ve troubleshooted endlessly but it’s not successful.

If you have already done a fresh install, then it can sometimes mean there are not enough resources. Encryption is a very tasking to the install and to the app in general.

What resources have you allocated to the VM? Also have you installed haveged?

Do you think haveged will help?
After all, I did the installation on two different systems (Centos 7 and Ubuntu 22.04, in Ubuntu 2 times)

I’ll try to put it on Ubuntu 20.04.

haveged way originally designed to produce additional entropy. These days it shouldn’t be needed on new kernels but when running a VM the resources allocated to it are variable and access to raw hardware is different.

How much RAM did you allocate? What kind of CPU did you allocate ( to the VM) ?

Of its not working with either OS, it might be the lack of sufficient resources. Any errors is the system logs of the VM?

2 CPU, 4 Gb RAM.
I removed the old OS on a virtual machine and installed a new one with Ubuntu 20.04

Try again with haveged installed and see if it makes any difference.

Before installation, I checked if haveged is installed in the system

I saw somewhere that PASSBOOK does not work with PHP 7.4. Maybe the information is outdated, but just in case I want to clarify. Does PASSBOLT work with this version of PHP?

PHP7.3 or higher are the requirements. Works with version 8 as well.

That’s how it turns out.Spin endlessly…

Maybe it’s Hyper-V?
There were no problems on VMware.

Found this, I think you are right, but I’m not sure we know why.

I tried it today to install on a Synology NAS and I had the same error.
It doesn’t matter if I user Ubuntu 22.04 or 20.04.
Now I tried it with Virtual Box on my laptop and the installation completed.
The next I try, is to export from Virtual Box and import on the Synolog NAS.

1 Like

Thanks @Sylvie68 for the additional symptom report and details.

The team is mostly out this weekend. I am noting this to @remy for when they return so someone can maybe speak to what requirement may not be met at this point in the installation process.

OK, Thanks @garrett!

1 Like