Updating from Passbolt version v2.13.5 to v3.2.1 on Ubuntu LTS 20.04.1

Hi all,

Just trying to find a guide to update my current version of Passbolt being v2.13.5 to the latest version being v3.2.1.

Passbolt is installed on my self-hosted Ubuntu 20.04.1 server.

I have followed the official guide, though, it is only updating the Ubuntu server itself and not Passbolt:

I have tried Googling it but have not had much luck. This is my first time wanting to update the version, so any help would be greatly appreciated.

Kind regards,


Hello @neucjc,

Hope you are doing well, as you are running an old version of passbolt, I guess you used the install scripts for your first install and then the documentation you linked to update a passbolt version install with the ubuntu package won’t work for you.

If you are sure that you installed passbolt with install scripts, you can use this documentation to upgrade from install scripts to ubuntu package, it will do the update and also ease the process for you to update your passbolt in the future Passbolt Help | Migrate passbolt CE from install scripts to Ubuntu package.

If you are unsure about your first install process, you can then execute this command :

dpkg -l passbolt-ce-server

You will either get this error saying that there is no package matching passbolt and then confirming you used the install scripts :

dpkg-query: no packages found matching passbolt-ce-server

In this case, you can use the link I provided you to upgrade passbolt CE from install scripts to Ubuntu package.

Or you will get information about the passbolt package you already installed, in this case just tell me and we will dig your issue together why your passbolt isn’t updating :slight_smile:


Hi Gerold,

Thanks for the reply. I ran the command and indeed found that I am running the install script version.

I went through the upgrade process and all the commands worked fine and the migration was ‘successful’. Though, when opening Passbolt now it shows the login page for a few milli seconds and then goes white (I have backups of the VM, so I can always restore it).

I also tried a new install of Passbolt on another VM and followed this guide: Passbolt Help | Install Passbolt CE on Ubuntu 20.04

Though when I do follow it and try and access the new Passbolt server via IP address once finished installing, it always goes to the “Welcome to Nginx” page and does not show the new Passbolt page setup.

I tried Googling around regarding the new install I have not found much help regarding it.



Hello @neucjc,

We already encountered this issue by the past, could you please check the solution in this topic Nginx welcome page after migrating to Ubuntu package (20.04.2), I guess your issue is related.

We didn’t reproduced it yet but we will plan to and update the documentation consequently if it appears to be needed.