Beginner question about instalation

Hello team!!

I am new with this, I need to know if passbolt could help us.
I tried to install it in debian 11, following all the steps:

But when I run the command to install passbolt (sudo apt install passbolt-ce-server), I get something like “Cannot find the package passbolt-ce-server”, translated to english
I am very begginer with this and my linux knowledge is poor too

Also, I would like to know the following, about the free version, to know if this will help us without installing this:

  • Is this multi-user? I mean, many users using this at the same time
  • In this case, Can I create different users to loggin? I mean, not the same username for everyone
  • It is possible to database to be stored in some free public site as google drive, dropbox, teams, etc?

Thanks in advance.

Hello @damian and welcome to the forum!

If you follow the instruction and it can’t find the package, maybe running the following command could help

sudo apt update

Then you might retry with the command

sudo apt install passbolt-ce-server

So, for information, apt is a package manager for Debian and Ubuntu that can help users to install programs on their machine. Usually, package managers like these ones require to know which package are available and where before being able to download them. This is what the command apt update is doing actually. It installs nothing, just make it aware of what’s available for download basically. Then, if it goes well, the apt install command should know where to find the package.

However, I’m quite surprised that you encounter such issue to be honest. I did a test again yesterday and it went well on my side. So, I wonder if you had some errors appearing during the process before the “install” command. Maybe the problem comes from somewhere else. Did you have errors?

And to answer to your questions, yes, passbolt is multi-user but not all users can see all passwords stored. You have to share them. A best practice is to create groups of users and share passwords with these groups.

You cannot host the database on google drive, teams or dropbox. You need a MySQL or MariaDB database.

Best regards,

1 Like

Hello guys, thanks!!!

I have tried to make “sudo apt update” but this did not change the results.
The previous steps did not get any error message.
Could it be related with debian version? Is there a debian version for servers?
I have Debian GNU/Linux 11 (bullseye) with a gui, dont know if this should work.
Thanks for all responses!


Normally what happens on the 3 first steps of the installation guide:

  • step 1: download a pre-installer file, that is used to prepare your server with required elements and also make sure the “apt update” command is run before going. This step only download the file and doesn’t execute it yet
  • step 2: another file is downloaded to make sure the first downloaded file is the desired one and hasn’t been corrupted somehow. The file is only downloaded, not used yet
  • step 3: with the file of the step 2, checks that the file of the step 1 is not corrupted. If the file is ok, then it runs it and set your server in a way it is ready to go on with the apt install command.

During these 3 steps, did you encountered any unexpected messages?
For instance did you have this message Bad checksum. Aborting?
Could you provide us with the results in the console from the 3 first steps please? It will help a lot.

[Edit] normally your Debian version should be fine by the way. I didn’t tested with a Debian having a GUI, but technically, it should be working the same way

[Edit 2] Also on step 3 if the pre-installer file is not the expected one, it removes it

Thanks Steph!

I now see that the 3rd step is deleting the sh file, this shows:
"Bad checksum. Aborting" && rm -f La suma coincide
./ línea 11: aviso: setlocale: LC ALL: no se puede cambiar el local (en_US.UTF-8):
ro o el directorio
sysctl: reading key “net.ipv4. tcp min tso segs”
PHP is already installed, you must execute this script on a vanilla server

I tried this downloading both files many times with the same result, allways the sh file is removed
Anyway, if I skip the 3rd step, with the sh file in the current directory, the result is the same

Any idea?
Thanks in advance.

Hello @damian,

The method you are using to install Passbolt expect a fresh server. If you install this way it will help you set up all services needed to run Passbolt such as Nginx and MySQL/Mariadb so it is best not to have other things installed.

As mentioned in the error log you provided, you already have PHP installed on your machine so the process exits and removes the install scripts, it then doesn’t have time to install dependencies and to setup the Passbolt sources file.

I would strongly advise you to install Passbolt on a vanilla server if possible in order to not interfere with already running application.

1 Like

You can try source install if you have the dependencies already installed, or try Docker installation to make it a bit easier