Blank page with passbolt badge after authentication

Server worked 2years with no issues. But last week lost access to all passwords.
All users after authorization have blank page with no access to passwords.
After healthcheck found an issue and fixed it: [FAIL] The temporary directory and its content are not writable.
Restarted the server, it is passing now, but issue still persist. Any ideas what I can else to try?
Passbolt version - 2.13.5

# sudo -H -u nginx bash -c "/var/www/passbolt/bin/cake passbolt healthcheck"

     ____                  __          ____
    / __ \____  _____ ____/ /_  ____  / / /_
   / /_/ / __ `/ ___/ ___/ __ \/ __ \/ / __/
  / ____/ /_/ (__  |__  ) /_/ / /_/ / / /
 /_/    \__,_/____/____/_.___/\____/_/\__/

 Open source password manager for teams
 Healthcheck shell


 [PASS] PHP version 7.3.33.
 [PASS] PCRE compiled with unicode support.
 [PASS] The temporary directory and its content are writable.
 [PASS] The public image directory and its content are writable.
 [PASS] The logs directory and its content are writable.
 [PASS] GD or Imagick extension is installed.
 [PASS] Intl extension is installed.
 [PASS] Mbstring extension is installed.

 Config files

 [PASS] The application config file is present
 [PASS] The passbolt config file is present

 Core config

 [PASS] Debug mode is off.
 [PASS] Cache is working.
 [PASS] Unique value set for security.salt
 [PASS] Full base url is set to https://passbolt....
 [PASS] App.fullBaseUrl validation OK.
 [PASS] /healthcheck/status is reachable.

 SSL Certificate

 [PASS] SSL peer certificate validates
 [PASS] Hostname is matching in SSL certificate.
 [PASS] Not using a self-signed certificate


 [PASS] The application is able to connect to the database
 [PASS] 23 tables found
 [PASS] Some default content is present
 [PASS] The database schema up to date.

 GPG Configuration

 [PASS] PHP GPG Module is installed and loaded.
 [PASS] The environment variable GNUPGHOME is set to /var/lib/nginx/.gnupg.
 [PASS] The directory /var/lib/nginx/.gnupg containing the keyring is writable by the webserver user.
 [PASS] The server gpg key is not the default one
 [PASS] The public key file is defined in config/passbolt.php and readable.
 [PASS] The private key file is defined in config/passbolt.php and readable.
 [PASS] The server key fingerprint matches the one defined in config/passbolt.php.
 [PASS] The server public key defined in the config/passbolt.php (or environment variables) is in the keyring.
 [PASS] There is a valid email id defined for the server key.
 [PASS] The public key can be used to encrypt a message.
 [PASS] The private key can be used to sign a message.
 [PASS] The public and private keys can be used to encrypt and sign a message.
 [PASS] The private key can be used to decrypt a message.
 [PASS] The private key can be used to decrypt and verify a message.
 [PASS] The public key can be used to verify a signature.

 Application configuration

 [FAIL] This installation is not up to date. Currently using 2.13.5 and it should be v4.0.0.
  [HELP] See.
 [PASS] Passbolt is configured to force SSL use.
 [PASS] App.fullBaseUrl is set to HTTPS.
 [PASS] Selenium API endpoints are disabled.
 [PASS] Search engine robots are told not to index content.
 [PASS] Registration is closed, only administrators can add users.
 [PASS] Serving the compiled version of the javascript app
 [PASS] All email notifications will be sent.

  1 error(s) found. Hang in there!

Hi @alexant14 Welcome to the forum!

There are many posts about this recently.

  • v4 extension requires at least v3 API (you have 2.13.5)
  • v3.x API requires at least php7.4
  • You need to upgrade your passbolt
  • temporary access is restored with v3 extension downgrade

See Passbolt v4 beta testing is now open 🚀 - #2 by garrett

Thank you for the fast reply,

I was able to find v3 extension and it solved issue temporary.
Now working on creating new passbolt server and moving there data.


Thank you @alexant14

We understand the frustration, it was very hard for us to maintain the retro compatibility for such a long period of time. Keep in mind that 2.13.5 was released mid 2020 and it was too complex to ensure that compatibility for all the platform.
All the guide to upgrade the version are there: Passbolt Help | Upgrade
And indeed, setup a new server will be much simpler.

Let us know