Can't login as admin after logging on with another user

Hello !

I recently set up Passbolt on Docker, everything worked just fine. While I was doing some tests, I did something stupid, which was logging off from my admin account and log in with another user account with the same web browser.
Now if I try to access my admin account, I land on the recovery page, but the mail is never sent. My SMTP is working just fine, as email test was successful and I was able to invite other users, so the issue is somewhere else.
I don’t know if this information could be useful, but I added my admin account through CLI.
I haven’t found anything to get my admin invitation link again without deleting and recreate the user.

Any clue ? Thanks a lot !

hey @Jorgen welcome to the forum. This issue does come up sometimes. The way to get back in with your account was posted here

Additionally you may want to access the database and run:
select email, subject, error, created, sent from email_queue;

To see what the error listed is on these emails.

1 Like

Thanks for the quick response @clayton !

Well, I’ve been able to get my user_id and token to get the link.
However I got this:

I tried with 2 differents links: https://<your_URL>/setup/recover/<user_id>/<token> and https://<your_URL>/setup/install/<user_id>/<token> but got the same result.

So what I’ve done was running this command on the database:
select email, subject, error, created, sent from email_queue;

It is weird because this account is already activated.
I enabled public registration but it doesn’t change anything, still have the same problem.

can you try with this query in your database:

SELECT users.username, user_id, token, type FROM authentication_tokens, users WHERE AND type IN ('register', 'recover') AND;
1 Like

I’ve been able to get the correct token thanks to you. I got my admin account back. Thanks a lot guys !
Maybe I should learn a lot more about databases… could be useful :sweat_smile:

1 Like

Cool, glad you solve it!

1 Like