DigitalOcean installer - MySQL issue


#1

Checklist
[x] I have read intro post: About the Installation Issues category
[x] I have read the tutorials, help and searched for similar issues
[x] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[x] I describe the steps I have taken to trouble shoot the problem
[x] I describe the steps on how to reproduce the issue

Steps

  • Created my server at DigitalOcean with their Marketplace Installer. Loads fine at: http://xxx.xxx.xxx.xxx
  • Set hostname in DigitalOcean as passbolt.[domain.com]
  • Created an A record in Cloudflare (grey cloud/proxy off) http://passbolt.[domain.com] (Worked)
  • SSH’ed into server as root and
    • When prompted by wizard, entered hostname as passbolt.[domain.com]
    • Selected “Auto” for SSL through Let’sEncrypt.
    • Obtained MySQL DB auth details as directed by Wizard.
  • Visited https://passbolt.[domain.com]/install as directed by instructions. (Works)
    • Selected Wizard configuration option.
    • Wizard reports:
      • Environment is configured correctly.
      • GPG is configured correctly.
      • SSL access is enabled.
    • Entered MYSQL DB auth details and clicked submit.
      • Fails with error “A connection could not be established with the credentials provided”. Please verify the settings.
      • Re-entered username and password obtained earlier. 2nd failure.
      • Try with username “root” 3rd failure.

Header info after submit

Summary
URL: `https://passbolt.[domain.com]/install/database`
Status: 200 OK
Source: Network

Request
POST /install/database HTTP/1.1
Content-Type: application/x-www-form-urlencoded
Pragma: no-cache
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Host: `passbolt.[domain.com]`
Accept-Language: en-ca
Cache-Control: no-cache
Accept-Encoding: gzip, deflate
Origin: `https://passbolt.[domain.com]`
Referer: `https://passbolt.[domain.com]/install/database`
Content-Length: 292
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0.3 Safari/605.1.15
Connection: keep-alive
Cookie: CAKEPHP=3b0grkgj0uhmvq464tnmu891tk; csrfToken=7530274866be7df0707c149907a051181b5a4799ceb4d7c28a6b751c9330762fd39d8cfec1346dc941d1efa65eb50d8749eb0e09584ef874a27f59057358cd5f; __cfduid=dc96adf147c7e30d1239fb7af8d55b7a81551398589

Response
HTTP/1.1 200 OK
Keep-Alive: timeout=5
Content-Encoding: gzip
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Referrer-Policy: same-origin
X-XSS-Protection: 1; mode=block
Date: Thu, 14 Mar 2019 20:45:45 GMT
Connection: keep-alive
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Transfer-Encoding: Identity
Access-Control-Expose-Headers: X-GPGAuth-Verify-Response, X-GPGAuth-Progress, X-GPGAuth-User-Auth-Token, X-GPGAuth-Authenticated, X-GPGAuth-Refer, X-GPGAuth-Debug, X-GPGAuth-Error, X-GPGAuth-Pubkey, X-GPGAuth-Logout-Url, X-GPGAuth-Version
X-Frame-Options: sameorigin
Content-Type: text/html; charset=UTF-8
X-Content-Type-Options: nosniff
Server: nginx/1.14.0 (Ubuntu)
X-GPGAuth-Version: 1.3.0
X-GPGAuth-Verify-URL: /auth/verify
x-download-options: noopen
X-GPGAuth-Logout-URL: /auth/logout
X-GPGAuth-Pubkey-URL: /auth/verify.json
X-GPGAuth-Login-URL: /auth/login
x-permitted-cross-domain-policies: all

Request Data
MIME Type: application/x-www-form-urlencoded
_method: POST
_csrfToken: 7530274866be7df0707c149907a051181b5a479xxxxxxxxxxx30762fd39d8cfec1346dc941d1efa65eb50d8749eb0e09584ef874a27f59057358cd5f
type: mysql
host: `passbolt.[domain.com]`
port: 3306
username: passbolt_usr_xxxxxxx
password: xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
database: passbolt_xxxxxxx

Sent inquiry to Cloudflare support but since it’s set to “DNS only” for the subdomain, Port 3306 should not be blocked.

Any insights anyone?


#2

Hi @skunkworks

MySQL database on the image is bound to listen localhost only. On the wizard you should use 127.0.0.1 as the mysql hostname


#3

Thank you.