Database: A connection could not be established with the credentials provided

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
[Yes if its needed] I provide relevant information about my server (component names and versions, etc.)
[Yes, if its needed] I provide a copy of my logs and healthcheck
[Yes, if its needed] I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

Hello everyone,

I REALLY need your help with my passbolt installation.

I want to install Passbolt on a VM in VMWare with Debian, because the company I work for wants to host it locally.
The private IP of the maschine is The local domain I want to use is pdmanager.cocolab. The Domain was created in a PFSense and other VMs can ping it.

Im using this guide for my installation: Install Passbolt on Debian 12 (Bookworm) | Passbolt documentation.

The Installation progess works fine. After I did: sudo apt install passbolt-ce-server I can configure the database etc.
This are my Settings:
“Create a passbolt database on the local mysql?”: YES
“MySQL administrator username:” ROOT
“Admin Password”: I leave it empty.
The other Settings like “Database User” I leave on default.

Than it asks me to setup nginxs etc.
I choose “none” and tip in my domain.
As I understand it, to get a automatic SSL Certificate with Lets Encrpyt you need a public domain etc.
I tried it but i got an error message instead, so i choose “None”.

In the next page “Database configuration” I get an Error Message.

I tried and my private ip adress.

What should I do? Did I make a mistake somewhere ealier?
I can give you more information if you need them.


hey @GLE welcome to the forum!

You mentioned this:

The other Settings like “Database User” I leave on default.

but in your screenshot you have the username set to admindb which I don’t believe is the default. During that initial portion of the install it created a database and user for you to use and it expects that information on this web portion of the set up.

Could you try with the credentials from the first part?

Hi Clayton!

Thank you for your fast replay!
Arent that the default settings?

I just wanted to go safe and did “sudo dpkg-reconfigure passbolt-ce-server” to reconfigure my settings.

Now I get Error Code 1045 (28000): Access denied for user Root_Luca@localhost (using password: NO)

Best regards


I continued guessing some passwords an now Im in step three!

Guess I had wrong inputs… :wink:

Thanks anyway.