Disable email notifications on one server


I have managed to have two passbolt instances running and replicating (for redundancy). Basically, I migrated one server to another and set-up master-master MySQL replication. This would work fine in the case where one is down, but you have to change DNS manually (This would be best if you have central DNS management such as through pfSense).
Now I have one issue. When I make changes on the passwords, I get double notifications, because it is happening on 2 servers. I have tried disabling in one server, but all are disabled.
How can I enable notification only in one server, so as to avoid multiple notifications on the same activity?
Attached is my set up.


Since you have master-master going on it makes sense that when you disable the setting on one it gets propagated to the other. The email settings are saved in the database.

To solve this double emailing you’ll need to disable the cronjob that sends emails on one of the servers. Downside here is if the one sending emails goes down and you failover to the other you’ll have to go in and turn on the cronjob again. On debian you can find that cronjob file here: /usr/share/php/passbolt/bin/cron

Thanks. This solved my use case. I just wanted a standby passbolt that is updated. I will re-enable notifications should the alive server be the one with notifications disabled.

How did you solve replication for the user’s GPG keys to decrypt the passwords?
I was thinking of doing something like this but I’m new to replication and backup for emergencies terms

Basically follow the process of migrating to a new server here Passbolt Help | Upgrade. It should be able to cater for the keys, and the users will login without requiring recovery of their accounts.