E-Mail SMTP server configuration Problem

Hello. I have installed the Passbolt application on my centos 7 based server. I have a problem in the e-mail smtp part during the installation phase. I use outlook.com as e-mail. In the test mail sending part

“Email could not be sent: stream_socket_client(): unable to connect to tcp://smtp-mail.outlook.com.:587 (Permission denied)”

I am encountering the error. What’s the problem?

Hi @ysnsolak :wave: and welcome to passbolt community forum :hugs:

I guess you have a SELinux issue :confused: Can you execute this command and give us its output ?

sudo audit2allow -a

Best regards,

1 Like



#!!! This avc can be allowed using one of the these booleans:
#httpd_can_network_connect, httpd_can_sendmail, nis_enabled
allow httpd_t smtp_port_t:tcp_socket name_connect;


It seems this rule is missing in our passbolt-selinux package:

We will publish an updated package with a fix. In the meantime, can you temporary disable selinux ?

You can open /etc/selinux/config and set SELINUX=permissive ?

It will let you use your smtp provider. I will keep you posted when the update will be available.


1 Like

hello. I did the steps you said, but my problem still persists. If I install another linux-based server instead of Centos, I wonder if the problem will be fixed? ( Ubuntu, Debian, Oracle ).


Did you reboot your server after the selinux configuration file modification?

You can see current selinux status with the command sestatus.


1 Like

Hi there
After _jc restart, my problem is solved, now I have installed and using the passbolt application without problems. Thank you for your help. Good work. :raised_hands:

1 Like

Thank you for the feedback. I will keep you posted when our passbolt-selinux package will be updated with the fix. So you will be able to use your SMTP provider with selinux enabled.


1 Like