Email problems. int php extension is installed but passbolt not detect

I’ve a passbolt working fine for 1 year but now I’ve a problem. Is not sending emails, I’ve checked all configs and are ok, the other CMS that has the server are sending emails, but passbolt not.
I read this command can solve the problem
./passbolt/bin/cake cleanup --dry-run
but when I did I’ve the error
PHP Fatal error: You must enable the intl extension to use Passbolt. in /var/www/passbolt/config/bootstrap.php on line 26

But I’ve the intl extension installed and working. If I do a <?php info() ?> looks fine

What can I do?


Hi @Will, please make sure the intl extension is enabled for command line interface as well:

php -m | grep intl

There is generally two php.ini configurations, one for the webserver (apache2?) and one for command line interface.

yes, it’s what you say about the two configurations.
I’have 3 versions of php in my server and I set the version for each site in apache virtual host .
My passbolt site is php 7.0 but the command line is php7.2-fpm

I’ve discovered this error today when I do the coomand:
php -v
PHP 7.2.19-1+0~20190531112637.22+stretch~1.gbp75765b (cli) (built: May 31 2019 11:26:38) ( NTS )
How can configure the command line with php7.0?

I’ve changed the php version used on terminal with this explanation:

After changed, the emails sent right away

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.