[fail] the application not able to connect the database


I had, a lot of difficulties to install.

Now I have this problem, Can you help me?


[FAIL] The application not able to connect to the database.

[HELP] Double check the host, database name, username and password in config/passbolt.php

[HELP] Make sure the database exlsts and is accesslble for the given database user.

[PASS] 1 tables found

[FAIL] NO default content found

[HELP] Run the install script to set the default content such as roles and permission types

[HELP] sudo su -s /bln/bash -c “/var/www/passbolt/bln/cake install” nginx

[FAIL] The datalbase not up to date

[HELP] Run the migration scripts:

[HELP] sudo su -s /bin/bash -c “/var/www/passbolt/bin/cake migrations migrate”

[HELP] See. https: //www/. passbolt.com/help/tech/update

I tried to execute the command, because the database is ok.

sudo su -s /bln/bash -c “/var/www/passbolt/bln/cake install” nginx

but follow the error:


Shell class for “Install”; could not be found. in

[/var/www/passbolt/vendor/cakephp/cakephp/src/console/ShellDispatcher. php, line 327]

thank you a lot for you help


There is a typo in your command. It should be : sudo su -s /bln/bash -c “/var/www/passbolt/bln/cake passbolt install” nginx

thank you, it’s work fine.

is there any execution log? it points to database error, but the settings are correct inside passbolt.php. and the database was created as described on the site. Like this:

$ mysql -u root -p
mysql > create database passbolt;
mysql > create user passbolt;
mysql > grant all on passbolt.* to 'passbolt'@'localhost' identified by 'strong_db_password';
mysql > flush privileges;
mysql > quit;

When I run the installer, it asks to see the problems by healthcheck, but it is the same as the log up.

thank you foir you help

What is the database (and version) you are trying to connect passbolt on ?

Mysql Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (i386) using readline 5.1

It looks like your version of mysql is very old (5.1.73), if I’m reading well the output you gave me.
I would suggest to upgrade to a newer version. Passbolt is compatible with mysql > 5.5 and < 8.0.

Thanks a lot! it’s works fine now!

1 Like