Fresh Install v3.1 - Can't send emails

[ X ] I have read intro post: https;//community,passbolt,com/t/about-the-installation-issues-category/12
[ X ] I have read the tutorials, help and searched for similar issues
[ X ] I provide relevant information about my server (component names and versions, etc.)
[ X ] I provide a copy of my logs and healthcheck
[ X ] I describe the steps I have taken to trouble shoot the problem
[ X ] I describe the steps on how to reproduce the issue

Been using Passbolt 2.X on Ubuntu 18 for a while and i’ve been loving it. I am a bit of a novice when working with linux so there was a learning curve to get everything set up but I did it. Now i’m upgrading to Passbolt 3.1.0 and Ubuntu 20.04.2 (a freshly created virtual machine), but i’m running into some trouble.

Following the steps in the install guide, my install appears to go fine. After fixing one error, everything is green in the health check. My main issue is the system will not send emails even though the test email during the install was successfully sent and received. Okay, so it’s probably the cron job, right? The emails not being sent FAQ says,

For installs from the Debian package … the cron job is automatically installed at /etc/cron.d/passbolt-{ce|pro}-server

This file does exist and says the following,


* * * * * www-data $PASSBOLT_BASE_DIR/bin/cron

So… does this mean I don’t have to create my own?

Some other thoughts & clues:
In the past (when I was running 2.X) I have been able to send emails by running sudo ./bin/cake EmailQueue.sender. If there were emails in the queue I would see a notice when these emails were sent out but this does not work for me anymore. I can still see all my emails waiting to go out if I run EmailQueue.preview. There are no errors displayed when i do this, and I don’t see anything about this in the logs (not sure if I’m checking all the right logs, though).

If I run ls -la /usr/share/php/passbolt/ it shows me that all files and directories are owned by root. Should this be, or should I chown everything to www-data? I see three of the following (possibly related?) error at the same day/time (about the time I think I was installing PB) in the passbolt error log,

Warning: Warning (2): chmod(): Operation not permitted in [/usr/share/php/passbolt/plugins/Passbolt/WebInstaller/src/Utility/WebInstaller.php, line 285]

Also, also:
For whatever it’s worth, I am running this behind an Nginx Reverse Proxy, but I don’t think that has anything to do with this issue. Passbolt 2.X ran fine behind the same proxy.

Can someone maybe point me in the right direction? Any help on this would be greatly appreciated!

Hi @ecov, you are correct about cron… no need to manually create. Root ownership of the files should be fine but the error you posted is related to the config folder and file permissions. The source code for that function is here: passbolt_api/WebInstaller.php at a37ced39a4ba94ae3e3a26b4937a283c6202e2b1 · passbolt/passbolt_api · GitHub

Regarding no email sent, check logs again. Maybe enable debug. Being behind a proxy should not effect the email issue.