I can't reach initial page but apache appears instead

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

I have follow the Passbolt Help | Install Passbolt CE on Debian 11 (Bullseye) but I tried to access initial page to finish installation

but when I go on a browser I have Apache2 Debian Default Page

I have already tried to uninstall Apache but the site is not found

Hello @Mathz and Welcome!

So, from what I understand, you had an Apache2 server that was responding instead of your Nginx server.
You removed the Apache2 server but now what do you see when reaching the page?

What I think is happening at the moment is that Nginx might have not started as Apache2 was running.

You could try the following to restart nginx

sudo systemctl restart nginx

If it’s not running then, there should be some errors you might be able to see by running the following:

sudo systemctl status nginx