Issue with Gnupg decryption in Cron job / Emails not sent


As reported by several people from the community, there is an issue with some installations, specifically the emails are not being sent because the decryption operation doesn’t work in the cron job. This issue is present either all the time (each time the cron job) or every hours or so.

Unfortunately none of the team managed to reproduce this issue so far, so we’re a bit struggling to fix this one. It’s possible that they are several issues, we’re not excluding this.

We’ve a 3.8.3 release schedule this afternoon that may fix the problem and if not give us more debug information. We also have a call scheduled with a user at 16:00 to try to understand what is the root cause of this.

We’ll keep you posted in this thread. Thank you for your patience and support.


Update: the call with the user was a different issue than email settings not being decrypted. It was a PAM issue, solved by commenting the module inside /etc/pam.d/cron. We’re not sure about the conditions that led them to this scenario, we’ll investigate further.

Another user reported the fix to work: Cron email notifications not working in VyOS · Issue #183 · passbolt/passbolt_docker · GitHub

Update: Tomorrow we release with the 3.8.3:

  • An improvement for the cron job log output for the cronjob so that we can get more info as to why the cronjobs are failing if they are for both docker and packages.
  • An improvement to the gnupg errors reporting improvement in the API
  • A potential fix (e.g. we suspect the email job may fail if for some reason the server key is not in the keyring).

Hi all!

Earlier today we published new Debian packages and RPM packages as well as docker images with increased logging and improved Gnupg treatment of settings for cron. We hope it will help those of you that are having SMTP issues.

Keep us posted if you upgrade.


I’ve updated our instance to 3.8.3 (Docker) but it’s still not working. We are using SES as provider.

@tobi can you open a new thread with the regular information (health-check, error message you are seeing, etc.) so that we can look into it?

I’ve opened another ticket for this issue: Issue sending SMTP mails via SES