Mails are not working - DB Issue?!

[x ] I have read intro post: About the Installation Issues category
[ x] I have read the tutorials, help and searched for similar issues
[ x] I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
[ x] I describe the steps I have taken to trouble shoot the problem
[ x] I describe the steps on how to reproduce the issue

Hi there,

I installed the currently newest version of Passbolt onto an Ubuntu Server 22.04.01 LTS with 2 Cores, 2GB RAM and 12GB storage. I did not use the local DB, because we have an extra DB-Server. I set up the mails with an M365-Account and the test mail was and is working perfectly. However, any notification mail is not sending.
When I looked in the database, I saw that in the email_quene Table, the fields email_from and email_name have null values. Thats also what the Error from Microsoft in the error-field said.
I found another topic with the same problem here, however I don’t know how it was resolved.
Any help would be kind, I am not a Linux expert.
I also reinstalled everything (including the OS), nothing worked for me.

Thank you!

Hi @Joo It’s really good news to hear the test email worked.

The email troubleshooting page is here so double check you didn’t miss a step: Passbolt Help | Why are my emails not being sent?

The email from and name fields can be modified in the /etc/passbolt/passbolt.php configuration file.

Hey @garrett
thank you for the fast reply. I already checked the page you are referring to, but couldn’t find anything wrong on my configuration.
Strange is, that I installed it on Ubuntu Desktop first (for testing) and it worked perfectly fine there.
I will look into the PHP file, whether I can find anything.