New Installation - PHP not processing

Centos 7 / Apache / MariaDB / PHP7

After installation, i try to follow the link to login for the new user and i can only see unprocessed PHP.
Have i missed some apache config ?

[root@localhost passbolt]# su -s /bin/bash -c “app/Console/cake passbolt healthcheck” apache

 ____                  __          ____  
/ __ \____  _____ ____/ /_  ____  / / /_ 

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Healthcheck shell


[PASS] PHP version 7.0.25
[PASS] PCRE compiled with unicode support
[PASS] The temporary directory and its content are writable
[PASS] The public image directory and its content are writable

Config files

[PASS] The core config file is present
[PASS] The database config file is present
[PASS] The email config file is present
[PASS] The application config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Unique value set for security.cipherSeed
[PASS] Full base url is set to
[PASS] App.fullBaseUrl validation OK.
[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl
[HELP] Check that the domain name is correct in app/Config/core.php
[HELP] Check the network settings

SSL Certificate

[FAIL] SSL peer certificate does not validate
[FAIL] Hostname does not match when validating certificates.
[WARN] Using a self-signed certificate


[PASS] Configured to use a supported database backend
[PASS] The application is able to connect to the database
[PASS] Not using a prefix for database tables
[PASS] 20 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded
[PASS] The server gpg key is not the default one
[PASS] The environment variable GNUPGHOME is set to /usr/share/httpd/.gnupg
[PASS] The directory /usr/share/httpd/.gnupg containing the keyring is writable by the user the webserver
is running as.
[PASS] The public key file is defined in app/config.php and readable.
[PASS] The private key file is defined in app/config.php and readable.
[PASS] The server key fingerprint matches the one defined in app/config.php.
[PASS] The server key defined in the app/Config.php is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.

Application configuration

[PASS] Using latest passbolt version (1.6.5)
[PASS] Passbolt is configured to force SSL use
[PASS] App.fullBaseUrl is set to HTTPS
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[PASS] Registration is closed, only administrators can add users.
[PASS] Serving the compiled version of the javascript app
[PASS] All email notifications will be sent.

Development Tools (optional)

[PASS] Phpunit is installed
[PASS] Phpunit version is 3.7.38

3 error(s) found. Hang in there!

[root@localhost passbolt]#

[ ] I have read intro post: About the Installation Issues category
[ ] I have read the tutorials, help and searched for similar issues
[ ] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[ ] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Did you install php-fpm? Have you tried restarting apache? If you installed first apache and then php, or installed both with a single yum command, then apache might not yet know about php.

Hmm i’ve restarted apache but no joy…
I’ll try NGINX and see what happens

This is not really a passbolt problem, but maybe this tutorial can help:

Thanks remy, i did say i thought it was an apache config issue and not a Passbolt issue.

Probably the install guides need a few extra steps for Apache… I used NGINX in the end and it’s working apart from emails which im looking at.

i did say i thought it was an apache config issue and not a Passbolt issue.

I didn’t say you didn’t warn us :wink:
I’m glad you’re making progress.

If your SMTP configuration is working but your emails still aren’t being sent, have a look at this post I made:

Really appreciate the help guys…
SMTP config is good but they only send when I run the queue command so not why they are not sending automatically.

[root@localhost passbolt]# su -s /bin/bash -c “app/Console/cake EmailQueue.sender > mail.log” nginx
You have new mail in /var/spool/mail/root

You have to setup the EmailQueue.sender command to be triggered as nginx via cron.

[root@passbolt passbolt]# crontab -u nginx -l
* * * * * /var/www/html/passbolt/app/Console/cake EmailQueue.sender >> /var/www/html/passbolt/app/tmp/logs/email.log 2>&1

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.