Newest Traefik version broke PassBolt

[ Y] I have read intro post: About the Installation Issues category
[ Y] I have read the tutorials, help and searched for similar issues
[Y ] I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
[Y ] I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

I am using Docker on a VPS to run passbolt community edition. I have been pulling and using the latest version of traefik. When I updated Traefik today with the latest version, I could not connect to the server on the web. I tried pulling Traefik 2.6 to get that working, but no luck. I ended up having to load a backup. I’ve done all the steps to update the image as normal. I have a couple questions about docker with passbolt:

What versions of Traefik and Mariadb shoud you use?
Why is the latest version of traefik not working on Passbolt CE?


I connect to the server after updating, but get the error: “Could not verify the server key. An Internal Error Has Occurred.” Why is this?

I also have this check shown as orange in the health check:
The passbolt config file is missing in /etc/passbolt/


I am using traefik in front of passbolt and wrote the initial documentation about how to use passbolt in docker with traefik to handle auto https with let’s encrypt.

I upgraded traefik today by replacing in my docker-compose file the 2.9 version with 3.0.

By manually starting the docker stack, I got this error message from Traefik:

$ docker-compose up --force-recreate
Recreating traefik_traefik_1 ... done
Attaching to traefik_traefik_1
traefik_1  | {"level":"error","error":"command traefik error: field not found, node: swarmMode","time":"2024-03-24T12:53:58Z","message":"Command error"}
traefik_1  | {"level":"error","error":"command traefik error: field not found, node: swarmMode","time":"2024-03-24T12:54:09Z","message":"Command error"}

It is just because Traefik Docker provider has been split into 2 providers (Docker and Swarn) and swarmMode doesn’t exist anymore with Docker provider.

So I removed swarmMode in traefik.yaml configuration file to fix my issue and my passbolt is working fine.


Thanks for the reply! I never got an error which is weird. I’ll try your trick and see what happens.

1 Like

You can use docker-compose logs -f to watch logs :slight_smile:

1 Like

Yea that didn’t work. I still get this. I think it wiped all the data somehow, guess I’ll have to load a backup every time I update.

Yea, I just switched back to my original image that was working and no luck. It won’t even let users recover an account because it does not recognize the emails. I have no idea how updating traefik deletes the data.

AH fixed it. I somehow didn’t have the correct password for my database in the compose file. I replaced it with the correct one and it’s all good.

1 Like