Passbolt 2.0.7 images are not working / loading please wait

Hi guys, I just updated my passbolt 1.6.0 to 2.0.7, and the health check seems ok.
But when i access to the passbolt, its not showing any pictures, but i can login with it.
After login , it’s not showing any password also. Only shows “loading, please wait” …
I tried to set the folder permissions, php-fpm, but it doesn’t help.
I am using Centos 7, php 7.2.5 , Mariadb and Nginx.

You probably have an issue with the fullbaseurl or URL rewriting or your nginx config is not pointing to the webroot.

My nginx config was pointing to the right webroot path, and the fullbaseurl in /var/www/config/passbolt.php was configured same as the previous version of passbolt.
I got no idea with the issues… The healthcheck only show the ssl error, cause I’m using a selfsign cert.

Check the network tab in your browser console. You will see which url it is trying to use and can’t reach.

Yes , from the network tab, it showing I have missing some files.
The login page: /css/themes/default/api_login.min.css?v=2.0.7 404 (Not Found)
And the main page is missing some files also.

/css/themes/default/api_main.min.css?v=2.0.7 404 (Not Found)
/js/app/steal.production.js?v=2.0.7 404 (Not Found)

Yes, if the URL looks correct then that’s typically a url rewriting issue. Double check your nginx config.

The webpage issues was fixed after i changed the nginx conf. Thanks !
But I got another issue now,the email wont send automatically.

I had change the command in crontab, by running the command

          • /usr/bin/su -c “/var/www/passbolt/bin/cake EmailQueue.sender > /var/www/passbolt/tmp/email.log” -s /bin/bash nginx

It still wont sending any email. However I run this command manually, it will send a mail. How can i fix this?
The passbolt folder permissions changed to nginx, permission rwxr-xr-x .
Tried to restart crond, there is no error in /var/log/crond
The mail setting was running correctly , I can send a mail if I run the command manually.


This issue is fixed ! Is my crontab issue. Thanks!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.