[SOLVED]Passbolt behind NGINX gets stuck on "Loading, please wait ..." after login with first created user

I set Passbolt behind NGINX proxy. Everything worked perfect until login part. When i enter my first user email and password, it gets stuck on “Loading, please wait”.

The interesting part is when i put my IP address and port instead of URL, I was able to login, but then my user profile page is somehow loaded without css.

Here is my core.php file :

Configure::write(‘App.fullBaseUrl’, ‘https://10.xx.xx.xx/passbolt’);


  • Web path to the public images directory under webroot.
  • If not set defaults to ‘img/’
    Configure::write(‘App.imageBaseUrl’, ‘passbolt/img’);


  • Web path to the CSS files directory under webroot.
  • If not set defaults to ‘css/’
    Configure::write(‘App.cssBaseUrl’, ‘passbolt/css/’);


  • Web path to the js files directory under webroot.
  • If not set defaults to ‘js/’
    Configure::write(‘App.jsBaseUrl’, ‘passbolt/js/’);

Anyone has suggestions?
Thank You.

@diego I realized we’re pointing at two solutions to similar issues. I’m unsure if there are some specifics to docker install compare to what i’m previoulsy describing in other post (e.g. set the fullbase https://domain/ without the directory name and let cakephp find it)

@diego When i set only IP ADDRESS, nginx returns “Not found”

Hi @Miodragl

Looks like you are using passbolt v1, is that correct? If that is the case I would recommend to upgrade to passbolt v2 since the subdirectory problem has been addressed.

Ok, can you please tell me if can i upgrade passbolt from command line somehow?

You need to update some config files as described in the help files here, depending on which type of install you are doing and to which version -> https://help.passbolt.com/hosting/upgrade

1 Like

I’m afraid without knowing the state of your setup it would be hard to give you a one line command to upgrade it to passbolt v2.

I suggest you to take a look on our help site that contains plenty of information on how to migrate from passbolt v1 to passbolt v2 in different scenarios https://help.passbolt.com

Ok, since i have no password stored on my current server, is there any instructions online how to install passbolt V2, because there are different config files from V1, as I can see ?

:slight_smile: https://help.passbolt.com/hosting/install#toc_gpg

1 Like

Ok, thank you guys, i will try to install passbolt v2 and if the new problem occurs, i will contact you again, if you are willing to help ofcourse :slight_smile:


Ok, guys, now I installed V2 and it works perfectly fine with NGINX proxy, but i have one more problem and that’s it: when I enter https://IP_ADDR/passbolt, browser shows: “Not secure” with red triangle in front of URL,
although i provided certificate, as you can se on the picture bellow:

Should i open new topic, i haven’t seen this problem on forum yet?

@Miodragl this is an issue with your (I assume self-signed) certificate, this is not related to passbolt.

@remy Ok, thanks anyway.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.