Passbolt installing without domain name

Hello guys,
I am trying to install Passbolt on ubuntuserver for local purpose.
We want to use it just for password depot.
So we do not want to set up a domain name. We want to use it
just via “” ip address.
But for the ssl as far as I understand at least a local domain is needed. Please correct me if I am wrong.
The server run on a hyper v .
Is it possible to use it directly via ip address?
Any help ?
Thanks in advance!


You can use https with an IP address. But it will be a self-signed certificate.

It means you will have to import it if you want the green padlock in your browser.

Have a look at this documentation, especially the “PRO Tip” : Debian/Ubuntu manual HTTPS configuration | Passbolt documentation.

To use the mobile app with self-signed certificate:


Hi Anatomic,
Thanks for your answer.
1- Is it possible it on CE edition , as well?
2-Will I just generate SSL key pair and deploy for nginx ?


Yes, it works for both CE and PRO and also any website :wink:

If your IP address is, here is the command to execute

openssl req -x509 \
    -newkey rsa:4096 \
    -days 3650 \
    -subj "/C=LU/ST=Luxembourg/L=Esch-Sur-Alzette/O=Passbolt SA/OU=Passbolt IT Team/CN=passbolt.domain.tld/" \
    -nodes \
    -addext "subjectAltName = IP:" \
    -keyout key.pem \
    -out cert.pem

I replaced DNS:passbolt.domain.tld with IP: and set a validity of 10 years instead of 120 days (I replaced -days 120 with -days 3650).

This command will create a key key.pem and a cert cert.pem you will be able to use by following the documentation: Debian/Ubuntu manual HTTPS configuration | Passbolt documentation.


Thanks Anatomic, Is this possible to do this on installation with Docker, as well?

Hi Hasan,

Yes, here is the documentation: Docker manual HTTPS configuration | Passbolt documentation.


Hi Anatomic,
Thank you very much. PassBolt good but documentation is extremely bad.

I am trying to install via Docker I encountered some problems

EMAIL_DEFAULT_FROM_NAME From email username ‘passmanager’
EMAIL_DEFAULT_FROM From email address ‘’
EMAIL_TRANSPORT_DEFAULT_HOST Server hostname ‘192.22’
EMAIL_TRANSPORT_DEFAULT_USERNAME Username for email server auth
EMAIL_TRANSPORT_DEFAULT_PASSWORD Password for email server auth passwordforpassmanager

First should I set 1 for SSL enabled?
I did so
export EMAIL_DEFAULT_FROM_NAME =‘passmanager’
export APP_FULL_BASE_URL=‘https://…178.22’
is this correct and enough?

The other question…

here did not work for me.
Result: -bash: exec: passbolt: not found

What is wrong with me?
If you have a link which explains for internal ip installation youtube please let me know. I am very exhuasted with passbolt.


There is nothing wrong with you, feel reassured :people_hugging: :slight_smile:

Using HTTPS with an IP address instead of a real domain name is not a common use-case but more like advanced usage. That’s why you have the feeling the documentation is not good enough.

You have this error because there is a missing \ in passbolt docker documentation. I let passbolt folks fixing it :stuck_out_tongue: I created a pull request but I am not sure if it is the correct way to update this doc.

Here is the updated command with the missing \:

docker-compose -f docker-compose-ce.yaml \
exec passbolt su -m -c "/usr/share/php/passbolt/bin/cake \
passbolt register_user \
-r admin" -s /bin/sh www-data

If you are looking for a better explanation about how to setup passbolt with docker I can recommand this Youtube video:

Regarding the email options, I let the passbolt team guide you. I am not familiar with O365 settings.


Hi Anatomic,
Thanks for long explanation. I saw there is a mistak with ‘\’ even I corrected it did not work still. it showed me the usage of docker-compse is bla bla . the parameters bla bla.
Btw I do not enforce to use the https for us. Because it will be in closed area. It is not accessed by publicly. But the problem is there is no explanation for the failed situation. In case of fail or error there should be explanation for this purpose.
Because Passbolt is used very commonly and the installation is very hard.
I have spent roughly one week to install that but useless. I am frustrated.
I want to use it just as password depot for our administration credentials. There will be just 3-4 user and no client usage.
HTTPS is not a must. But Even I followed your instruction the HTTPS did not work for me. Installation is successed but on browser says no valid certificate. Perhaps I need to put the cert on my machine,as well.
And OpenPgp armored key was alos problematic. It says
“Please note that passbolt does not support OpenPGP key protected with a secret.”
Luckiky I passed it by creation with command instead of doing by UI.
But the SMTP is very problematic. I followed the forum as well. but no result.
Can you take a look my smtp topic ,as well ?